6

With Cinnamon 2.6 and two monitors stacked up vertically, I configure the panel (task bar?) to be at the top of the upper window. Now, when I shut down the laptop, disconnect the 2nd monitor, the top one, and reboot, I am left without the panel.

Is it possible to get the panel back in this situation, possibly some dconf-editor magic or other command line tweak?

3
  • This is nasty indeed. Should be reported as a bug imo.
    – donquixote
    Commented Jun 16, 2016 at 15:00
  • Do you think this is cinnamon special or rather gnomish.
    – Harald
    Commented Jun 17, 2016 at 6:09
  • Somewhere I was told the correct thing is to report things in the respective distro first (the one where the problem was observed), and they discuss what's next. E.g. Mint.
    – donquixote
    Commented Jun 17, 2016 at 17:34

2 Answers 2

9

After searching for all things related to panel with in dconf-editor I figured it out. Here is the command line with gsettings:

gsettings set org.cinnamon panels-enabled "['1:0:top']"

As far as I guess the syntax, the value means the following:

  • brackets denote a list, although I did not manage to enter more than one value
  • single quotes surround the value
  • the first 1 seems to be an ID or just a number of the panel, since adding a second panel puts a 2 in this position
  • the second digit was 1 before denoting the disconnected monitor, using 0 selected the laptop screen
  • top may also be bottom and defines where the panel ends up

For completeness, here is a small script that I run when the panel is either missing from the single screen or on the wrong screen when I connect the big monitor again. Works for me:

#!/bin/bash
screens=$(xrandr | grep -c ' connected ')
echo "found $screens displays"

if [ "$screens" = 1 ]; then
  gsettings set org.cinnamon panels-enabled "['1:0:top']"
else 
  gsettings set org.cinnamon panels-enabled "['1:1:top']"
fi
2
  • 2
    If anyone else has the problem that this script removes the bottom panel, just add , '2:0:bottom' to the list. Like this: gsettings set org.cinnamon panels-enabled "['1:0:top', '2:0:bottom']". Apparently the space after the , is important.
    – arne.z
    Commented Jun 12, 2017 at 20:57
  • 2023 and this solution is still needed... I've put the script into my startup applications
    – devLui
    Commented Jul 31, 2023 at 6:51
1

I know this is a 6-year-old question, but the problem still occurs in november 2021 :) I am running a fresh Mint 20.2 with Cinnamon.

The script in the other answer fixes it, but you have to run it every time. So for anyone else coming across this, this is my case. I frequently connect and disconnect a second "monitor" (it's a HDMI output connected to a USB capture device on another PC, so my own PC's output becomes a webcam input). I don't want my "audience" to see my panels, open windows, tasks etc., not even temporarily.

So what apparently happens is that as soon as you connect that second monitor, the system decides that that new monitor is my new primary monitor, and the panel immediately moves to that monitor.

So, simply connect the second monitor, then go to display settings, set the normal monitor as primary, apply the settings, then move the panel to the proper monitor, and that worked for me. Hope this helps anyone else, it kept me busy for over an hour :)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .