4

I have Linux Mint 17.2 on a lenovo T400. It has the Intel 5100 AGN wireless card installed.

At my university, there is an unsecure guest wireless SSID and a WPA/WPA2 secured SSID which authenticates based on username/password. I can connect to the unsecured network with little trouble, but am wholly unable to connect with the WPA connection. It will ask for my password, attempt connection, and then ask for the password again, ad infinitum.

This is not dependent upon how long the machine has been running, whether it has been suspended, etc. It has been this way since I installed this OS.

dmesg immediately after disconnecting from unsecured and attempting to connect to secured:

sp4rg0n@sp4rg0n-ThinkPad-T400 ~ $ dmesg
...
[ 2899.302943] wlan0: deauthenticating from 08:cc:68:cc:fd:51 by local choice (Reason: 3=DEAUTH_LEAVING)
[ 2899.305487] cfg80211: Calling CRDA to update world regulatory domain
[ 2899.309223] cfg80211: World regulatory domain updated:
[ 2899.309227] cfg80211:  DFS Master region: unset
[ 2899.309229] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[ 2899.309232] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[ 2899.309234] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[ 2899.309236] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm), (N/A)
[ 2899.309238] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[ 2899.309239] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[ 2913.499595] wlan0: authenticate with 08:cc:68:cc:fd:5f
[ 2913.502680] wlan0: send auth to 08:cc:68:cc:fd:5f (try 1/3)
[ 2913.523336] wlan0: authenticated
[ 2913.524051] wlan0: associate with 08:cc:68:cc:fd:5f (try 1/3)
[ 2913.628054] wlan0: associate with 08:cc:68:cc:fd:5f (try 2/3)
[ 2913.629384] wlan0: RX AssocResp from 08:cc:68:cc:fd:5f (capab=0x101 status=12 aid=0)
[ 2913.629390] wlan0: 08:cc:68:cc:fd:5f denied association (code=12)
[ 2913.918053] wlan0: authenticate with 08:cc:68:cd:01:3f
[ 2913.922846] wlan0: send auth to 08:cc:68:cd:01:3f (try 1/3)
[ 2914.022154] wlan0: authenticated
[ 2914.024064] wlan0: associate with 08:cc:68:cd:01:3f (try 1/3)
[ 2914.025595] wlan0: RX AssocResp from 08:cc:68:cd:01:3f (capab=0x101 status=12 aid=0)
[ 2914.025602] wlan0: 08:cc:68:cd:01:3f denied association (code=12)
[ 2914.231147] wlan0: authenticate with 08:cc:68:cc:cd:3f
[ 2914.234561] wlan0: send auth to 08:cc:68:cc:cd:3f (try 1/3)
[ 2914.260298] wlan0: authenticated
[ 2914.260569] wlan0: waiting for beacon from 08:cc:68:cc:cd:3f
[ 2914.368066] wlan0: associate with 08:cc:68:cc:cd:3f (try 1/3)
[ 2914.370491] wlan0: RX AssocResp from 08:cc:68:cc:cd:3f (capab=0x111 status=0 aid=1)
[ 2914.373564] wlan0: associated
[ 2914.373890] cfg80211: Calling CRDA for country: US
[ 2914.377564] cfg80211: Regulatory domain changed to country: US
[ 2914.377573] cfg80211:  DFS Master region: unset
[ 2914.377578] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[ 2914.377585] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2700 mBm), (N/A)
[ 2914.377591] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 1700 mBm), (N/A)
[ 2914.377596] cfg80211:   (5250000 KHz - 5330000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (0 s)
[ 2914.377601] cfg80211:   (5490000 KHz - 5600000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (0 s)
[ 2914.377606] cfg80211:   (5650000 KHz - 5710000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (0 s)
[ 2914.377611] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 3000 mBm), (N/A)
[ 2914.377616] cfg80211:   (57240000 KHz - 63720000 KHz @ 2160000 KHz), (N/A, 4000 mBm), (N/A)
[ 2939.005918] wlan0: deauthenticating from 08:cc:68:cc:cd:3f by local  choice (Reason: 3=DEAUTH_LEAVING)
[ 2939.009798] cfg80211: Calling CRDA to update world regulatory domain
[ 2939.018975] cfg80211: World regulatory domain updated:
[ 2939.018985] cfg80211:  DFS Master region: unset
[ 2939.018990] cfg80211:   (start_freq - end_freq @ bandwidth), (max_antenna_gain, max_eirp), (dfs_cac_time)
[ 2939.018997] cfg80211:   (2402000 KHz - 2472000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[ 2939.019003] cfg80211:   (2457000 KHz - 2482000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[ 2939.019008] cfg80211:   (2474000 KHz - 2494000 KHz @ 20000 KHz), (300 mBi, 2000 mBm), (N/A)
[ 2939.019013] cfg80211:   (5170000 KHz - 5250000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)
[ 2939.019018] cfg80211:   (5735000 KHz - 5835000 KHz @ 40000 KHz), (300 mBi, 2000 mBm), (N/A)

sp4rg0n@sp4rg0n-ThinkPad-T400 ~ $ lspci -nn | grep 0280
03:00.0 Network controller [0280]: Intel Corporation PRO/Wireless 5100 AGN [Shiloh] Network Connection [8086:4237]

FWIW the wifi manager also complains at the first attempt about the lack of a CA certificate. It offers two options: ignore, and choose certificate. I ignore.

Does anybody have insight as to what the problem might be? Thanks ahead of time.

0

Enterprise wireless solution used by the University will require installation of certificate. Check with University IT for obtaining the certificate. The Peap or other settings needed by Linux may not be provided. What I use: KDE network manager

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.