0

After a while of inactivity the fullscreen console fades to black until I press a key.
I want to disable the fade to black on my fullscreen console running in a VirtualBox.

I'm running Debian 8 Jessie and I'm not using a window manager.

1

Solution part 1: Configure kbd

Debian uses kbd, search for BLANK_TIME in /etc/kbd/config:

# screen blanking timeout.  monitor remains on, but the screen is cleared to
# range: 0-60 min (0==never)  kernels I've looked at default to 10 minutes.
# (see linux/drivers/char/console.c)
BLANK_TIME=30

Changing BLANK_TIME=0 will disable blanking, see Change Linux console screen blanking behavior.

Problem: Bug in Jessie

If this doesn't work, you're probably affected by bug #771161 / bug #750631 in Jessie.

Solution part 2: Workaround for systemd

Edit /etc/init.d/kbd and change line 222 from

setterm $setterm_args

to

TERM=linux setterm > /dev/tty1 $setterm_args

Technical details can be found in the bugreport above.

  • It did not work. – SenpaiSilver Oct 28 '15 at 1:27
  • Bug #771161, see my updated answer. – Jan Oct 28 '15 at 8:08
  • I was affected by the bug. – SenpaiSilver Oct 28 '15 at 9:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.