I have a Linux system (Debian testing) with some video files I would like to play on my Playstation 3 (an original, unmodified PS3). I can connect the PS3 to my home network using either WLAN at 54Mbps, or using a 100MBit LAN, which is tunneled over power sockets using a pair of Devolo powerline adapters, operating at a speed of about 4 MB/s.

I know that DLNA would be the way to go, I've tried several DLNA servers for Linux (fuppes, mediatomb, minidlna, xbmc). None of those worked reliably. Either no media appears, or if, then the files randomly stop after some minutes, and it's not possible to fast forward or reverse the videos.

Now the questions:

  • I'm not sure what is the problem with DLNA. Is it that I need more bandwith, or is DLNA a bad protocol, or is the implementation of those servers buggy or incompatible with the PS3?
  • Are there other methods to connect devices remotely to my PS3? I have heared it's possible to tunnel USB devices other Ethernet using IP, but I haven't found anything of value using Google.

Currently I'm using an USB stick for media playback, but this solution feels somewhat clumsy!

UPDATE: Important thing I forgot to mention -- if I replace the PS3 with my work Laptop (Windows XP SP3) and mount the video share over the same Devolo Ethernet connection using samba, then video playback works flawlessly.

UPDATE 2: It's been some time since I posted this question, but I've finally managed to connect my PS3 to my computer by means of a real Ethernet cable. Guess what? The problem persists, video playback pauses every 10 or 15 seconds for one second. I'm 99.9% sure it's not a problem with the network connection.I'm using PMS right now, and the transcode buffer is always full at 400MB, with bitrates around 1 - 2 Mb/s.

Any other ideas what may be the problem?

PROBLEM SOLVED: See my answer.

  • I'd first try the easy way to outrule connection drops and other problems potentially caused by the Devolo adapters: connect directly with an ethernet cable and compare. – rozcietrzewiacz Nov 3 '11 at 12:19
  • The fact that video playback works well over that connection using samba does not mean that the connection is not the source of problems in case of other programs. – rozcietrzewiacz Nov 3 '11 at 13:21
  • Yeah yeah I know, just thought that might be valuable information that, at least, the connection works with some method. I'll fetch an ethernet cord and test it without PowerLAN. – hochl Nov 3 '11 at 13:38
  • Just to keep this up to date, I still have no cable that is long enough. Might take some time. – hochl Nov 7 '11 at 14:24

I use Ps3 Media Server over a wired 100m connection with perfect results. My Sony TV and Xbox 360 are also able to stream from PS3 media server with no issues.

Wireless does not work at all for 720/1080p files.

Edit: Fast forward/pause etc also work on the PS3. You can also set the max speed of your receivers.

  • PMS always worked well for me. I used it for 2 years and it was the most reliable media server I have ever used. I would call it more reliable that even Windows7 media server (which also works to a PS3). Up-point on this answer. – djangofan Feb 1 '12 at 22:00

I agree with the comment about ruling out the network situation.

I've been using mediatomb for a long while now and the only problem i've had is a lack of time in setting up mkv transcoding. That said i've been running a 1Gbs link between my linux box (Ubuntu 11.04 amd64).

While i agree that media tomb is a pretty well, unfriendly piece of software it does work.

I configured it with an initial scan, followed up with scheduled scans. I found using the inode watching configuration to be quite a resource hog and very buggy.

I'm not sure what is the problem with DLNA. Is it that I need more bandwith, or is DLNA a bad protocol, or is the implementation of those servers buggy or incompatible with the PS3?

Probably both, try out a gigabit ethernet link if you can to rule in/out the network side and then try out which DLNA/upnp server is the most stable for you. PS3 Media Server works great a lot of the time, but requires a few more resources than media tomb and I'm running mine on an amd 1.3Ghz system so its a bit too resource intensive for me.

  • Hmm, I somewhere have a CAT5 for the test (but it's most probably too short), so I'll check to see if that helps. Unfortunately the whole setup is only 100mbps, so it might still fail. If that is the case I'm hosed, because there is no way for a permanent cable connection, except that I could dig open my walls ... but the flat was refurbished just some months ago, that would hurt :/ – hochl Nov 3 '11 at 12:52

Ok, I have finally solved the problem. It seems that there were two problems that, when combined, reduced transfer rates while streaming media. The first was that some update to Debian somehow messed with the firmware files for my NIC. I reinstalled all firmware packages. The second problem was the MTU of 1500, I reduced it to 1452. After those two changes video streaming runs flawlessly. What a relief!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.