I'm packaging some Python packages currently without RPMs, and some of those depend on others that I'm packaging.
While packaging I noticed a format where people do:
Require: python(pkg-name), but I'm trying to understand whether there's any particular syntax to using this? Because when it's used it doesn't seem to care about versions of the required package.
Requires: Python(gocd-cli) >= 0.9
Shows up in the requires list after I build my RPM:
$ rpm -qp --requires dist/gocd-cli.encryption.blowfish-1.0-1.noarch.rpm Python(gocd-cli) >= 0.9 python(abi) = 2.6 python-crypto rpmlib(CompressedFileNames) <= 3.0.4-1 rpmlib(PayloadFilesHavePrefix) <= 4.0-1
This package installs perfectly fine, despite the gocd-cli package version >= 0.9 hasn't been built and made available yet.
In summary what I'm trying to understand is:
- How is
Requires: Python()supposed to be used?
- What is the
Python()portion called? I've also seen it for Ruby, Perl and others…