1

I have Ubuntu running in VMWare workstation 12. I have a USB ethernet adapter which appears as eth1, and is statically assigned 192.168.0.10

My dnsmasq.conf is:

port=0
domain-needed
bogus-priv
server=8.8.8.8
interface=eth1
no-hosts
no-resolv
dhcp-host=60:9e:29:f5:c6:b1,192.168.0.31,24h
#dhcp-range=192.168.0.50,192.168.0.99,12h

I have alternated between the dhcp-range option, and tesing with the dhcp-host option for a specific client. Neither makes any difference.

Listening with tcpdump -i on eth1, I see the following:

tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth1, link-type EN10MB (Ethernet), capture size 262144 bytes
22:23:03.845805 IP 0.0.0.0.bootpc > 255.255.255.255.bootps: BOOTP/DHCP, Request from 60:9e:29:f5:c6:b1 (oui Unknown), length 300
22:23:05.550081 IP 0.0.0.0.bootpc > 255.255.255.255.bootps: BOOTP/DHCP, Request from 60:9e:29:f5:c6:b1 (oui Unknown), length 300
22:23:07.354164 IP 0.0.0.0.bootpc > 255.255.255.255.bootps: BOOTP/DHCP, Request from 60:9e:29:f5:c6:b1 (oui Unknown), length 300

Syslog does not reveal errors, and shows dnsmasq thought the syntax was fine. The service is confirmed to be running. Network manager is disabled.

WHat else could be the cause of this issue?

0

I think you need to have at least one dhcp-range entry to enable dhcp at all. You can use

dhcp-range=::,static

if you are only serving the one IP address. Add log-dhcp for some debug.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.