3

I would like to set my desktop background to a JPG wallpaper, but I cannot seem to. I have tried to by right-clicking the desktop and selecting "Desktop Preferences", but even when I select a JPG wallpaper the desktop background defaults to the select background colour I selected. I do not appear to have the same problem with PNG wallpapers, just JPG wallpapers.

I am running Gentoo Linux, through a VirtualBox machine, if relevant.

enter image description here

3
  • 2
    forums.gentoo.org/viewtopic-p-6406262.html maybe?
    – DK Bose
    Oct 26 '15 at 9:31
  • Is x11-wm/openbox compiled with the svg USE Flag?
    – eyoung100
    Oct 29 '15 at 22:01
  • I found this Q&A while googling and noticed that you have not yet chosen to accept an answer to this question. I am curious: did these approaches solve your problem?
    – AdminBee
    Nov 3 '20 at 9:20
2

I encountered this problem when lxde-meta was emerged without having set the "desktop" profile. This means that the 'jpeg' USE flag is not set (along with all other imagine flags).

LXDE can still be installed, but when it pulls in the package "gdk-pixbuf" (responsible for loading images) it is compiled without jpeg support. This causes the black background (image can't be loaded) and also the default image viewer (gpicview) being unable to open jpgs. PCManFM thumbnails are also affected.

It can be fixed by running:

euse -E jpeg jpeg2k
emerge -UDua @world

To add the 'jpeg' & 'jpeg2k' USE flag globally and then re-emerge any packages with USE flags which have changed since compilation.

I also needed to recompile the dependencies of "gdk-pixbuf" by running:

emerge -ae gdk-pixbuf

This shouldn't be required as far as I can tell, but is likely needed due to necessary libraries not being in place if only the packages affected by the USE flag are re-emerged.

Possible USE flags for "gdk-pixbuf" and thier current state can be easily found by running:

equery uses gdk-pixbuf
0

You need to have 'jpeg' USE flag set in order to be able to do that, please confirm that you have it enabled.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.