2

I try to make msfupdate inside the actual kali Linux sana repository. I don't understand the dependencies. for ex. I have xpdf <= 3.03-11 but 3.03-10 should be installed - where's the problem?

If I understand it well, <=3.03-11 doesn't mean 3.03-10 is out of range, because 3.03-10 < 3.03-11 is true, right? First I got an error

The following packages have unmet dependencies:
  libfontconfig1: Damaged: xpdf (<= 3.03-11) but 3.03-10 to be installed
E: Error caused by interruptions pkgProblemResolver :: Resolve; This could have been caused by retained packages.

I ran apt-get install reinstall xpdf and it seems to be installed. I tried again msfupdate, there's the next error

The following packages have unmet dependencies:.
  network-manager-gnome: Depends: network-manager (> = 0.9.10) but 0.9.4.0-10 to be installed
  ppp: Damaged: network-manager (<0.9.8.8-7 ~) but 0.9.4.0-10 to be installed
E: Error caused by interruptions pkgProblemResolver :: Resolve; This could have been caused by retained packages

Also <0.9.8.8-7 doesn't mean 0.9.4.0-10 is out of range because 0.9.4.0-10 < 0.9.8.8-7 is also a true statement.

My question: I don't know how much dependency errors are waiting to appear. Should I continue installing every error message output manually or is there a better way? I found this topic about a bug. I don't know but maybe it depends to my problem https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=727070 . Maybe someone could find a more moderate title for my question.

0

Apparently these aren't dependencies. Look at the message

libfontconfig1: Damaged: xpdf (<= 3.03-11) but 3.03-10 to be installed

These are packages which damage another, so the xpdf must not for it to be <= 3.03-11 to be installable.

  • Sorry i dont understand this part "must not for it to be <= 3.03-11 to be installable". Do you mean i need <3.03-11 or >3.03-11? If the first statement is true, i cant see errors because i have 3.03-10 and thats <3.03-11. if the second statement is true i would assume i have to upgrade my actual package, right? But if that is the highest version number in the repo, how can i upgrade it? i also ran apt-get update && apt-get upgrade 2 times today - my laptop crashes twice and i had to resetup. Could you tell me how to solve the problem? – linux-newbe Oct 25 '15 at 23:29
  • Sorry for the push but maybe someone could explain me that. It seems @Thomas Weinbrenner is not responding anymore but i have a problem understanding his answer. – linux-newbe Oct 26 '15 at 1:26
  • Sorry, it was late night here and I had to sleep. You need a package > 3.03-11, but I can't tell you where to get it. – Thomas Weinbrenner Oct 26 '15 at 5:22

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.