I try to make msfupdate inside the actual kali Linux sana repository. I don't understand the dependencies. for ex. I have xpdf <= 3.03-11 but 3.03-10 should be installed - where's the problem?
If I understand it well, <=3.03-11 doesn't mean 3.03-10 is out of range, because 3.03-10 < 3.03-11 is true, right? First I got an error
The following packages have unmet dependencies: libfontconfig1: Damaged: xpdf (<= 3.03-11) but 3.03-10 to be installed E: Error caused by interruptions pkgProblemResolver :: Resolve; This could have been caused by retained packages.
I ran apt-get install reinstall xpdf and it seems to be installed. I tried again msfupdate, there's the next error
The following packages have unmet dependencies:. network-manager-gnome: Depends: network-manager (> = 0.9.10) but 0.9.4.0-10 to be installed ppp: Damaged: network-manager (<0.9.8.8-7 ~) but 0.9.4.0-10 to be installed E: Error caused by interruptions pkgProblemResolver :: Resolve; This could have been caused by retained packages
Also <0.9.8.8-7 doesn't mean 0.9.4.0-10 is out of range because 0.9.4.0-10 < 0.9.8.8-7 is also a true statement.
My question: I don't know how much dependency errors are waiting to appear. Should I continue installing every error message output manually or is there a better way? I found this topic about a bug. I don't know but maybe it depends to my problem https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=727070 . Maybe someone could find a more moderate title for my question.