0

Yesterday I did apt-get update && apt-get upgrade to make my system up-to-date. It went through without any error.

After rebooting my Menu Bar 'disappeared', there's just a dark gray bar without any icons on it.
When clicking on the place where the Menu Icon would be, it shows all applications installed, but the strange thing is, that there is only the text and the application icons.

I then tried to open the terminal, it opened, but it was not visible. (I know that the terminal was there, since the mouse icon changed when hovering over the center of the screen, where the terminal would be.)
After that I wanted to take a look at some logs, but when opening the file system the Window was also not visible...
Also when entering screensaver mode the display remains black instead of showing GLmatrix.

Everything else looks normal, the Desktop Icons are there, and Context Menus are showing.

I don't know how to fix this, since I can't see anything when using my terminal, and I don't want to make a mistake, because I have some important data on my Linux Partition.

Any help to solve that problem would be appreciated!

0

After some trial and error I found out, that it was a problem with my GPU driver (AMD Catalyst 15.9).
Uninstalling the driver didn't worked, because libOpenCL.so.1 was changed by some application.
Searching through my logs I found out, that the culprit was the wine package, which changed the OpenCL file.

The solution was to force uninstall, rebooting and reinstall the GPU driver.

0

I've just uninstalled AMD driver and everything went fine. For those who want to know how to remove driver, try this:

cd /usr/share/ati

Then:

sudo sh ./fglrx-uninstall.sh

Solution found here.

  • Alternatively you could also do sudo aticonfig --uninstall. – SilverTiger Apr 11 '16 at 18:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.