My goal is to add files (in particular, a ringtone) to my LG GS170 cell phone. I'm running Ubuntu linux (and crunchbang on another machine, but the same problem persists there). When I plug the phone into my machine via USB, I see it when I run lsusb:

Bus 002 Device 008: ID 1004:6000 LG Electronics, Inc. VX4400/VX6000 Cellphone

but it doesn't show up in the /media directory as I'd hoped it would. Thus my question is:

How can I add files to my phone when it's connected via usb to my machine?

Edit: Below is what was output when I ran sudo udevadm monitor and then plugged in my phone.

monitor will print the received events for: UDEV - the event which udev sends out after rule processing KERNEL - the kernel uevent

KERNEL[1320439577.540674] add
/devices/pci0000:00/0000:00:1d.0/usb2/2-1 (usb) KERNEL[1320439577.553409] add
/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1:1.0 (usb) KERNEL[1320439577.555385] add
/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1:1.1 (usb) KERNEL[1320439577.558373] add
/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1:1.2 (usb) UDEV [1320439577.580299] add /devices/pci0000:00/0000:00:1d.0/usb2/2-1 (usb) UDEV [1320439577.621843] add
/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1:1.1 (usb) UDEV [1320439577.621894] add
/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1:1.2 (usb) KERNEL[1320439577.652034] add /module/cdc_acm (module) UDEV [1320439577.652421] add /module/cdc_acm (module) KERNEL[1320439577.655490] add
/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1:1.0/tty/ttyACM0 (tty) KERNEL[1320439577.655541] add /bus/usb/drivers/cdc_acm (drivers) UDEV [1320439577.655762] add
/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1:1.0 (usb) UDEV [1320439577.656031] add /bus/usb/drivers/cdc_acm (drivers) UDEV [1320439577.871264] add
/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1:1.0/tty/ttyACM0 (tty)


There are at least three possibilities, depending on how the phone is configured:

  1. It might already be visible as some kind of mass storage device. In that case, you might expect it to show up as any other external storage and be mountable under /media. But not necessarily (the system might ignore it because of unknown type). To make sure that the device is not already partially recognized, run sudo udevadm --monitor, then plug the phone, next hit Ctrl+C and paste the text here or on some pastebin-like site.

  2. The phone might have two usb modes in which it operates. You'd then need to switch the mode (which might default to modem or some similar) to mass storage. This might be possible either through the phone settings, or done automatically on subsequent connects or forced from the computer-side using a tool like USB_modeswitch.

  3. Some phones use a separate communications mechanism introduced some time ago by Nokia. On linux, there is a software package called gnokii that provides access to such devices. (Look up in your system repositories rather than downloading from the site.)

|improve this answer|||||
  • 1
    I've edited my question to include the result of sudo udevadm monitor. I don't know how to interpret it. If you do, please advise. – Quinn Culver Nov 4 '11 at 20:50
  • This confirms the second scenario - your phone is seen as a modem by default (it is used with cdc_acm modem module which triggers creation of /dev/ttyACM0 modem pseudo-tty). – rozcietrzewiacz Nov 4 '11 at 23:13
  • ...So try to look in phone documentation or on the web, how to switch it to mass storage mode (in phone documentation this might be called very differently!) If that fails, try the suggested tool. – rozcietrzewiacz Nov 5 '11 at 0:02
  • But I could try USB_modeswitch first, right? – Quinn Culver Nov 5 '11 at 2:02
  • Sure you can. But it may or may not work. If you have problems, try googling for solutions by other owner of such phone. Use the string "1004:6000 LG Electronics" (quoted) in your searches. – rozcietrzewiacz Nov 6 '11 at 23:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.