0

I recently found out about vim-pathogen, and installing vim plugins on my Mac has been working great. I tried using vim-pathogen on an external Linux cluster, but as soon as I clone a plugin repository into the .vim/bundle directory, I suddenly can't even open vim. A copy of my session is shown below. How do I fix this?

lindsb@rrlogin:~$ ls .vim
lindsb@rrlogin:~$ cat .vimrc
lindsb@rrlogin:~$ mkdir -p ~/.vim/autoload ~/.vim/bundle && \
> curl -LSso ~/.vim/autoload/pathogen.vim https://tpo.pe/pathogen.vim
lindsb@rrlogin:~$ ls .vim/*
.vim/autoload:
pathogen.vim

.vim/bundle:
lindsb@rrlogin:~$ echo -e "execute pathogen#infect()\nsyntax on\nfiletype plugin indent on" > .vimrc
lindsb@rrlogin:~$ cat .vimrc
execute pathogen#infect()
syntax on
filetype plugin indent on
lindsb@rrlogin:~$ vi
lindsb@rrlogin:~$ git clone https://github.com/Townk/vim-autoclose .vim/bundle/vim-autoclose
Cloning into '.vim/bundle/vim-autoclose'...
remote: Counting objects: 326, done.
remote: Total 326 (delta 0), reused 0 (delta 0), pack-reused 326 
Receiving objects: 100% (326/326), 97.85 KiB | 0 bytes/s, done.
Resolving deltas: 100% (132/132), done.
Checking connectivity... done.
lindsb@rrlogin:~$ ls .vim/*
.vim/autoload:
pathogen.vim

.vim/bundle:
vim-autoclose
lindsb@rrlogin:~$ vi
*** glibc detected *** vim: double free or corruption (fasttop): 0x00000000197ee800 ***
======= Backtrace: =========
/lib64/libc.so.6[0x326da714af]
/lib64/libc.so.6(cfree+0x4b)[0x326da757ab]
vim(clear_tv+0x4e)[0x453c7e]
|      |      |
|      |      |
V      V      V
[ a bunch more lines of similar error output ]

I'm not savvy enough to learn much of anything from the error output

  • 1
    There is an SO site dedicated to vi and vim. You might get an answer there sooner. The only thing I can suggest is try with a different plugin. That should tell you if the problem is with the autoclose plugin or not. – Bram Oct 25 '15 at 7:41
  • @Bram Didn't know that, I'll try my luck there. I did try with other plugins and got the same result. Thanks! – Ben Lindsay Oct 25 '15 at 12:10
1

I reposted my issue on the Vi and Vim Beta site and figured out the problem with the help of Christian Brabandt. For the sake of completeness, my issue was caused by an old version of vim. I installed locally by cloning the vim git repo then executing ./configure --prefix=$HOME/usr/vim && make && make install within the top directory of the vim repo. ($HOME/usr/vim is where I wanted vim installed) The new vim worked great with the pathogen plugin installation method, but it opened really slowly. By analyzing the startup time with vim --startuptime out.log I found that setting up the clipboard was taking up most of the startup time. Following the instructions in this post I found that vim -X opened much faster, so I added set clipboard=exclude:.* to my .vimrc file. Now everything works great.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.