1

Scenario -

SSH client, Windows laptop with Samba enabled (port 445. Don't care about netbios)

SSH server "TestingLAB". This machine has 2 interfaces, "publicIP" which I use to connect from my Windows laptop, "172.30.171.1" private IP.

Another machine "MyMachine". This machine has 1 interface, "172.30.171.100" which is only accessible from "TestingLAB" (which serves as the gateway)


Now, when I launch a SSH connection from my laptop so - (Cygwin)

ssh -R 11223:0.0.0.0:445 TestingLab

I am able to do a Samba mount on TestingLab by doing

mount -t cifs //localhost/share -o port=11223,


However, when I launch a SSH connection from my laptop so -

ssh -R 172.30.171.100:11223:0.0.0.0:445 TestingLab

Why am I not able to my Windows laptop share on "MyMachine".

Forward tunnels to "MyMachines" work, so why doesn't ReverseTunnels to MyMachine work?


Note, gatewayPorts is set to ClientSpecified, I also tried setting gatewayPorts to all. AllowTCPforwarding is set too. Basically, I have tried all sane settings, but a socket is never opened on "MyMachine" ever. However, when I Do forward tunnels, the data gets sent. For instance, the usual

ssh -L 80:172.30.171.100:80 TestingLab

Lets me do http://localhost on my laptop, and "MyMachine"'s web page pops up.

0

You must log in to answer this question.

Browse other questions tagged .