2

I have installed CentOS on Virtual Box. I had CentOS-7-x86_64-DVD-1503-01 downloaded it from a torrent.

I ran the following command;

nmcli d

Which tells that only loopback is there. I enabled host-only from Virtual Box interface and re-run the command, still the same result.

I want to enable network on it and also access it from my windows.

Note: My CentOS has only CLI no GUI.

Here are my VM Settings: updating it after first answer

CentOS - VM-Internet Settings

CentOS - Network Information

1

This looks like a case of RTM for Virtualbox.

From https://www.virtualbox.org/manual/ch06.html#network_hostonly:

..when host-only networking is used, VirtualBox creates a new software interface on the host which then appears next to your existing network interfaces. In other words, whereas with bridged networking an existing physical interface is used to attach virtual machines to, with host-only networking a new "loopback" interface is created on the host.

Since you're describing yourself as a beginner, I suggest you go with a bridged network. You'll find all the information how to set it up in the link above.

4
  • I did that, but still the same result. any idea ? – vicky Oct 24 '15 at 16:41
  • Your VBox net settings seem to be fine. Did you reboot Centos? Can you copy-paste the output of "ip link"? – vic Oct 24 '15 at 16:53
  • thanks vic, I have added a screenshot in the question. have a look. – vicky Oct 24 '15 at 17:06
  • I got curious and did a search on the net. It seems that Centos sometimes won't recognize new NICs automatically. But I'm really no expert on Centos, let's wait for someone else with experience. In the meantime, you might want to copy paste failures in your syslog. Another idea: maybe just make a new install with the new settings. Might be the quickest solution. – vic Oct 24 '15 at 17:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.