2

My speakers does not seem to work under FreeBSD 10.2-RELEASE .All drivers are loaded using kldload snd_driver. What to do?

pciconf -lv:

hostb0@pci0:0:0:0: class=0x060000 card=0x50001458 chip=0x27708086 rev=0x02 hdr=0x00
vendor = 'Intel Corporation'
device = '82945G/GZ/P/PL Memory Controller Hub'
class = bridge
subclass = HOST-PCI
pcib1@pci0:0:1:0: class=0x060400 card=0x50001458 chip=0x27718086 rev=0x02 hdr=0x01
vendor = 'Intel Corporation'
device = '82945G/GZ/P/PL PCI Express Root Port'
class = bridge
subclass = PCI-PCI
hdac1@pci0:0:27:0: class=0x040300 card=0xa0021458 chip=0x27d88086 rev=0x01 hdr=0x00
vendor = 'Intel Corporation'
device = 'NM10/ICH7 Family High Definition Audio Controller'
class = multimedia
subclass = HDA
uhci0@pci0:0:29:0: class=0x0c0300 card=0x50041458 chip=0x27c88086 rev=0x01 hdr=0x00
vendor = 'Intel Corporation'
device = 'NM10/ICH7 Family USB UHCI Controller'
class = serial bus
subclass = USB
uhci1@pci0:0:29:1: class=0x0c0300 card=0x50041458 chip=0x27c98086 rev=0x01 hdr=0x00
vendor = 'Intel Corporation'
device = 'NM10/ICH7 Family USB UHCI Controller'
class = serial bus
subclass = USB
uhci2@pci0:0:29:2: class=0x0c0300 card=0x50041458 chip=0x27ca8086 rev=0x01 hdr=0x00
vendor = 'Intel Corporation'
device = 'NM10/ICH7 Family USB UHCI Controller'
class = serial bus
subclass = USB
uhci3@pci0:0:29:3: class=0x0c0300 card=0x50041458 chip=0x27cb8086 rev=0x01 hdr=0x00
vendor = 'Intel Corporation'
device = 'NM10/ICH7 Family USB UHCI Controller'
class = serial bus
subclass = USB
ehci0@pci0:0:29:7: class=0x0c0320 card=0x50061458 chip=0x27cc8086 rev=0x01 hdr=0x00
vendor = 'Intel Corporation'
device = 'NM10/ICH7 Family USB2 EHCI Controller'
class = serial bus
subclass = USB
pcib2@pci0:0:30:0: class=0x060401 card=0x50001458 chip=0x244e8086 rev=0xe1 hdr=0x01
vendor = 'Intel Corporation'
device = '82801 PCI Bridge'
class = bridge
subclass = PCI-PCI
isab0@pci0:0:31:0: class=0x060100 card=0x50011458 chip=0x27b88086 rev=0x01 hdr=0x00
vendor = 'Intel Corporation'
device = '82801GB/GR (ICH7 Family) LPC Interface Bridge'
class = bridge
subclass = PCI-ISA
atapci0@pci0:0:31:2: class=0x010180 card=0xb0021458 chip=0x27c08086 rev=0x01 hdr=0x00
vendor = 'Intel Corporation'
device = 'NM10/ICH7 Family SATA Controller [IDE mode]'
class = mass storage
subclass = ATA
none0@pci0:0:31:3: class=0x0c0500 card=0x50011458 chip=0x27da8086 rev=0x01 hdr=0x00
vendor = 'Intel Corporation'
device = 'NM10/ICH7 Family SMBus Controller'
class = serial bus
subclass = SMBus
vgapci0@pci0:1:0:0: class=0x030000 card=0x35251458 chip=0x0a6510de rev=0xa2 hdr=0x00
vendor = 'NVIDIA Corporation'
device = 'GT218 [GeForce 210]'
class = display
subclass = VGA
hdac0@pci0:1:0:1: class=0x040300 card=0x35251458 chip=0x0be310de rev=0xa1 hdr=0x00
vendor = 'NVIDIA Corporation'
device = 'High Definition Audio Controller'
class = multimedia
subclass = HDA
re0@pci0:2:5:0: class=0x020000 card=0xe0001458 chip=0x816710ec rev=0x10 hdr=0x00
vendor = 'Realtek Semiconductor Co., Ltd.'
device = 'RTL-8110SC/8169SC Gigabit Ethernet'
class = network
subclass = ethernet

and dmesg | grep pcm:

pcm0: <NVIDIA GT21x (HDMI/DP 8ch)> at nid 5 on hdaa0
pcm1: <NVIDIA GT21x (HDMI/DP 8ch)> at nid 5 on hdaa1
pcm2: <NVIDIA GT21x (HDMI/DP 8ch)> at nid 5 on hdaa2
pcm3: <NVIDIA GT21x (HDMI/DP 8ch)> at nid 5 on hdaa3
pcm4: <Realtek ALC888 (Rear Analog 7.1/2.0)> at nid 20,22,21,23 and 24,26 on hdaa4
pcm5: <Realtek ALC888 (Front Analog)> at nid 27 and 25 on hdaa4
pcm6: <Realtek ALC888 (Rear Digital)> at nid 30 and 31 on hdaa4
pcm7: <USB audio> on uaudio0

Please help! :)

2
  • 1
    Have you tried playing a sound on all of the possible outputs? It's quite likely that it's just a matter of setting the default output device. Which device are your speakers plugged in to?
    – cas
    Oct 24, 2015 at 12:29
  • Thanks for the comment, I have already tried testing and with no succes but the mixer shows that the sound card is Realtek ALC888 ,speakers are connected directly to PC.
    – user117203
    Oct 24, 2015 at 12:40

1 Answer 1

2

The system is probably defaulting to using your nVidia card's sound.

Change the default device by looking at the list you showed. Say you wanted output to the jack on the front panel; you need pcm5 for that.

Add this line to /etc/sysctl.conf:

hw.snd.default_unit=5  

(the 5 being the pcm5 numeric part). Then do:

service sysctl restart

You must log in to answer this question.