3

i'm facing a strange problem with my newly installed Debian 8 box : default static routes are missing the 0.0.0.0 destination route.

$ sudo route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
10.0.0.0        172.18.224.1    255.0.0.0       UG    0      0        0 eth0
172.16.0.0      172.18.224.1    255.240.0.0     UG    0      0        0 eth0
172.18.224.0    0.0.0.0         255.255.255.0   U     0      0        0 eth0
192.168.0.0     172.18.224.1    255.255.0.0     UG    0      0        0 eth0

Thus I'm unable to connect to the internet with this setup.

I've checked the interfaces config file and there is nothing wrong here:

$ sudo cat /etc/network/interfaces
# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto eth0
iface eth0 inet dhcp

/etc/network/interfaces.d/ is also empty:

$ sudo ls /etc/network/interfaces.d/
$ 

I'm lost. Where are the default static routes set ? On every other Linux box I own, everything works perfectly by default. For instance, here is what I get on my Linux Mint box:

$ sudo route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         172.18.224.1    0.0.0.0         UG    0      0        0 eth0
10.0.0.0        172.18.224.1    255.0.0.0       UG    0      0        0 eth0
172.16.0.0      172.18.224.1    255.240.0.0     UG    0      0        0 eth0
172.18.224.0    0.0.0.0         255.255.255.0   U     1      0        0 eth0
192.168.0.0     172.18.224.1    255.255.0.0     UG    0      0        0 eth0

I know I could add the 0.0.0.0 static route to the config of the eth0 interface, but I'd like to understand why it is not there in the first place.

  • Could be a problem with your DHCP server? Did you try if other devices can reach the internet? – migrc Oct 23 '15 at 10:07
  • Yes, my other devices can connect to the internet perfectly. – Eric MORAND Oct 23 '15 at 10:10
  • do you have network-manager installed? that grotesque abomination can mess up your network in all sorts of horrible ways. – cas Oct 23 '15 at 10:34
  • Try enabling /etc/dhcp/dhclient-enter-hooks.d/debug by setting RUN=yesin the script. – cas Oct 23 '15 at 10:39
  • @cas: OK, I did it. What am I supposed to look at now ? And I don't have network-manager installed. – Eric MORAND Oct 23 '15 at 11:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.