I attempted to setup bash shell by default on Mac OS X (Yosemite) Terminal app and zsh shell by default on iTerm2 app. However, it is either bash shell or zsh shell for both the apps.

$ chsh -s /bin/zsh

sets up a zsh shell for both the apps. While iTerm2 Preferences --> Profiles (Command) option set to /bin/zsh --login doesn't load up zsh shell by default for iTerm2 app if bash shell is setup for Terminal app.

Any simple suggestions?


A user has one shell. A basic environment is setup up when you log in to your computer. $HOME, $LOGNAME, $USER, $TMPDIR, and $SHELL variables are set. Also, the $PATH variable is set to the system PATH. Some of these variables are set by reading info in Apple's version of open directory instead of reading the traditional /etc/passwd. Apple's terminal emulator, Terminal.app, can be set to open another shell instead of your shell set in open directory. Preferences>Startup>Shells open with:>Command radio button>complete path to the shell you wish to run in the text field.

  • That seems workable. I was trying the other way around and setting a zsh command in iTerm2 preferences. – Shah-G Oct 23 '15 at 13:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.