1

I am running Debian Jessie on my Thinkpad X220. Yesterday, after flashing a new BIOS on the laptop, the brightness keys stopped working on Debian. I can change the brightness during the BIOS bootup though.

Sounds kinda strange to me. Any ideas?

update

It looks like the brightness controls are disabled by default. Here is the relevant output from dmesg

[    2.016833] systemd[1]: Set hostname to <thinkpad-x220>.
[    2.192092] thinkpad_acpi: ThinkPad ACPI Extras v0.25
[    2.192171] thinkpad_acpi: http://ibm-acpi.sf.net/
[    2.192258] thinkpad_acpi: ThinkPad BIOS 8DET69WW (1.39 ), EC unknown
[    2.192331] thinkpad_acpi: Lenovo ThinkPad X220, model 4291Y3H
[    2.193207] thinkpad_acpi: detected a 16-level brightness capable ThinkPad
[    2.200276] thinkpad_acpi: radio switch found; radios are enabled
[    2.200401] thinkpad_acpi: possible tablet mode switch found; ThinkPad in laptop mode
[    2.200496] thinkpad_acpi: This ThinkPad has standard ACPI backlight brightness control, supported by the ACPI video driver
[    2.200496] thinkpad_acpi: Disabling thinkpad-acpi brightness events by default...
[    2.202578] thinkpad_acpi: rfkill switch tpacpi_bluetooth_sw: radio is unblocked
[    2.203332] thinkpad_acpi: Standard ACPI backlight interface available, not loading native one
[    2.203637] thinkpad_acpi: Console audio control enabled, mode: monitor (read only)
[    2.205397] input: ThinkPad Extra Buttons as /devices/platform/thinkpad_acpi/input/input5
[    2.305667] thinkpad_ec: thinkpad_ec 0.41 loaded.
  • As a temporary workaround, I am writing to the /etc/power/backlight/intel_backlight/brightness file. – feverDream Oct 22 '15 at 17:33
  • Do you mean /sys/...? Otherwise, check that the thinkpad_acpi module still loads, looks for messages in dmesg and possibly try various brightness_mode settings as described in the documentation. – Ferenc Wágner Oct 23 '15 at 19:23
  • Thanks for the dmesg tip. I see more information related to the brightness settings, I updated the question accordingly. And yes, I meant to write sys instead of etc :) – feverDream Oct 26 '15 at 23:24
1

It looks like there are quite a few solutions for the problem. The one that worked for me is via the xbacklight tool. I was able to map the XF86_Brightness* keys to the command in my window manager (DWM).

While its not perfect. It gets the job done.

  • Don't the names of the XF86_Brightness* buttons depend on the hardware? How did you find the right names? – Dr. Nefario May 26 '16 at 12:26
  • I used the tool xev to look at the name-mappings for different keys on my keyboard. – feverDream May 26 '16 at 17:40
  • Ah,ok. Sadly xev doesn't show me anything when I hit the combination of buttons for brightness control... My machine is Asus g56jr (for documenting purposes). – Dr. Nefario May 28 '16 at 9:06
  • Nice. I have an old g51jx running arch. Unless I am wrong, I had to install a xorg package that came with the keysym.h which has all the mappings. A quick hack would be to look at the hex representation of the key using xev and hard-code it. – feverDream May 31 '16 at 17:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.