1

Someone has changed my default runlevel to 6 so whenever I start Ubuntu it reboots..

Can anyone help me by suggesting some solution how to change my default runlevel?

1

Ubuntu has recovery shell option, which is accessible through grub menu's Advanced Options for Ubuntu. Remember to remount system with mount / -o rw,remount in order to allow changes to the system.

Alternatively, you can get to the grub menu, highlight Ubuntu, press e to edit the entry. Add init=/bin/bash, change default runlevel, reboot. Related link

There's also liveCD/ liveUSB recovery option.

Consult the ubuntu wiki for changing runlevels as well as booting to single user mode

1

Boot in single user mode (probably edit the boot command, adding a "1" at the end), and once the system is running, change the default runlevel back.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.