5

I have a Bluetooth headset Suicen AX610. My system is Debian 8.1.

I want to do run my headset, but I can't.

The debian 8.1 can find the headset,

enter image description here

But, the debian 8.1 can't pairing the headset,

enter image description here

I try to set Connection for on, but does not work

I don't install any packages. Because I looked many websites and each one says to set up the Bluetooth in a different way.

For instance, install a single package

$ sudo apt-get install bluez-tools

or install a lot of packages

$ sudo apt-get install bluez-audio pavucontrol bluez-firmware bluez-tools

or ...

$ sudo apt-get install bluez-utils bluez-gnome bluez-alsa

Can anyone help me with this question?

My bluetooth folder:

$ ls /etc/bluetooth/
input.conf  main.conf  network.conf  proximity.conf

=========================================================================

I solve this problem, but my solution isn't good and I can't explain my solution. I use trial and error method.

  1. Install a lot of packeges

    $ sudo apt-get install gnome-bluetooth pulseaudio pulseaudio-module-bluetooth pavucontrol blueman bluetooth bluez

  2. Edit /etc/default/bluetooth to enable the following

    HID2HCI_ENABLED=1 HID2HCI_UNDO=1

  3. Get ???

    $ hcitool con

    Connections: < ACL 00:11:67:00:52:55 handle 2 state 1 lm MASTER AUTH ENCRYPT

  4. Create .asoundrc

    $ sudo pico ~/.asoundrc

    pcm.bluetooth { type bluetooth device "00:11:67:00:52:55" profile "auto" }

    pcm.pulse { type pulse }

    ctl.pulse { type pulse }

    pcm.!default { type pulse }

    ctl.!default { type pulse }

  5. Reboot the system

  6. pairing by system tray

  7. $ sudo killall pulseaudio

  8. pairing again

5

You might just need to delete the pairing, then in terminal enter sudo pactl load-module module-bluetooth-discover then pair with the headset

2

sudo service bluetooth restart

This restores my headset as an output device in gnome sound settings, as it sometimes disappears. The headset syncs/pairs/connects, but does not appear in the control panel (or alsamixer) and so I cannot switch audio devices.

1

With blueman-applet I did it for a bluetooth speaker like this without restarting pulseaudio:

  • Run blueman-applet
  • Pair my bluetooth speaker
  • Right click it in blueman-applet window
  • Choose "Connect -> Audio Sink"
  • In pavucontrol in "Configuration" tab, switched my sound card from "Analog Stereo Duplex" to "Off" and chose "High Fidelity Playback (A2DP Sink) for my speaker.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.