0

So, I'm using a system with Fedora 20 installed, running a KDE 4.14.7 desktop. (I don't have root access so please no complaints about why I don't just upgrade my distro.)

I have just installed Eclipse Mars.1 (in my home directory), and it runs fine, but - the tooltips I get (e.g. hover line error descriptions) appear as black-on-black (!)

I've seen some similar complaints online, from several years ago, about this problem on Ubuntu systems, but that's not me... also, note that I'm not root, so I can't change any KDE or GTK system-wide defaults, only personal settings.

What can I do?

Notes:

  • I've seen suggestions to use "gnome-color-chooser" and fiddle with its settings, but I don't have that.
  • I've tried changing the KDE tooltip background, no effect.
  • I've tried the Eclipse Color Theme add-on, and with some themes the background is dark gray, or the foreground color is dark gray; but I still can't edit just that (and dark gray on black is not good enough either).
  • None of these suggestions have worked either.
  • 1
    Fedora 20 is out of maintenance, upgrade. – vonbrand Oct 20 '15 at 19:11
  • @vonbrand: As I said above, I'm just a user on that machine, I can't upgrade. – einpoklum Oct 20 '15 at 19:27
1

I know this is an old question relating to KDE 4, but I thought I'd just chime in with how I solved this in KDE Plasma 5 (Kubuntu):

  1. Open System Settings.
  2. Click on Colors (in the Appearance section).
  3. Un-tick Apply Colors to non-Qt Applications.
  4. Click on the Apply button.

Correct Tool-tip Colors for GTK Apps in KDE

  • Thanks for the answer, but I can no longer check since all of my versions have changed... – einpoklum Aug 19 '17 at 23:32
1

Here's what worked for me with Eclipse Mars and Fedora 24.

You need to run Eclipse using GTK 2, and change the tooltip colours in your chosen GTK theme. My theme is Zukitre/ so I edited the gtkrc file here:

sudo vi '/usr/share/themes/Zukitre/gtk-2.0/gtkrc'

Find the line that sets tooltip_bg_color and tooltip_fg_color and change it as follows:

gtk-color-scheme   = "tooltip_bg_color:#f5f5c5\ntooltip_fg_color:#000000" # Tooltips.

Then run eclipse using GTK2 by setting the following environment variable:

export SWT_GTK3=0
  • Under 1 year is old to you... :-( anyway, thank you for the effort, but the thing is that I don't have root access at all. Can you adapt your answer with user-specific files & paths to change? – einpoklum Jul 21 '16 at 11:38
  • @einpoklum: have you tried just export SWT_GTK3=0; eclipse? that fixed it for me under ubuntu without touching anything. – ted Aug 9 '16 at 20:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.