1

Actually I am having Debian Linux 8 installed in my system. For the first few days Debian GUI came directly whenever I started.

I don't know why, but after one week while I powered on the system, command prompt (Terminal) came directly. I tried to change it to GUI mode but its not worked out. After a lot of frustration I used startx to get the GUI mode

Now the problem is, when I powered on the system, command prompt (terminal) is coming normally and responding for all the commands like "username", "password" and if I give startx the GUI window is coming but not responding for any command, (looks like hanging) and even if I move the mouse the mouse cursor also not coming.

How to resolve the issue?

  • I use RHEL/CentOS and unfamiliar with Debian flavor (so I don't know the exact file to edit), but it sounds like your default runlevel has been changed. What you want is runlevel 5, multi-user mode with GUI. Also probably it would help to learn about virtual terminals, since you actually have more than one of them. – Wildcard Oct 20 '15 at 10:23
  • Welcome to stackexchange, by the way! I posted the above as a comment because I didn't actually answer your question. But I hope I gave you a starting point for your own research. – Wildcard Oct 20 '15 at 10:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.