xdg-open opens normal web pages in Firefox, such as xdg-open http://google.com. However, images do not. For example, xdg-open https://i.imgur.com/JfKwovX.jpg opens the image in Gwenview. I tried setting Firefox as default for (all?) urls with

xdg-mime default firefox.desktop x-scheme-handler/http
xdg-mime default firefox.desktop x-scheme-handler/https
xdg-settings set default-web-browser firefox.desktop

However, this doesn't seem to work for *.jpg urls. How can I make xdg-open open all urls in Firefox?

up vote 3 down vote accepted

I've managed to fix this by going to System Settings -> Applications -> Web Browser and setting parameter Open http and https URLs to in the following browser -> firefoxSystem settings screenshot

This works with KDE 5, but should work similar in previous versions.

  • This seems like it should work… but it doesn't! It was originally on the first option, but changing it to the second made no difference; it still opens in Gwenview. I even did kbuildsycoca5; kquitapp5 plasmashell; plasmashell. – Sparhawk Oct 26 '15 at 11:26
  • @Sparhawk It's strange. Have you tried to upgrade to the lastest version, recheck settings and reboot (or restart all applications including plasma)? – Vladimir Protasov Oct 27 '15 at 20:18
  • I'm running Arch Linux with a fully updated system. I restarted just in case, but there was no difference… but after the restart it had reverted, and changing this setting again fixed it! Thanks. – Sparhawk Oct 27 '15 at 20:54

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.