0

Can someone explain to me why I am getting this shell prompt when I'm in the /home directory, and how to get rid of it?  I am using zsh.

I want it to display only the following:

user@host ~ %

but it displays:

user@host ~ (svn)-[jp2014_213276_567222:1] %

I want to get rid of the part from (svn) up to the ~.

Output of echo $PS1:

%B%F{red}%(?..%? )%f%b%B%F{blue}%n%f%b@%m %B%40<..<%~%<< %b%F{magenta}(%fsvn%F{magenta})%F{yellow}-%F{magenta}[%F{green}2510_1331544_1331256%F{red}:%F{yellow}1%F{magenta}]%f %#
  • 2
    Why what keeps showing? What precise feature of that screenshot do you want to get rid of? – Tom Hunt Oct 19 '15 at 20:32
  • this right part from user@host ~, so (svn)-(blabla123123) keeps showing when I open /home and before using svn it was normal – speedoz Oct 19 '15 at 20:37
  • 4
    Please edit your question and include the output of echo $PS1. – terdon Oct 19 '15 at 20:49
  • Is that stuff at the bottom the response to terdon's request? If so you might want to give it some context, like "Here's the output of echo $PS1" or something. Otherwise it just looks like line noise – roaima Oct 19 '15 at 21:09
  • Yes that is the output of echo $PS1 and the bottom part of code is the right side of user@host -> (svn)-(name od directory) – speedoz Oct 19 '15 at 21:27
1

It looks like you've initialized your home folder as a svn repo. Fix with:

mv ~/.svn ~/.svn.bak

Alternatively, if you're not using svn, you can disable the svn components of vcs_info. Add a line like this, after you have sourced oh-my-zsh or whatever:

zstyle ':vcs_info:*'  enable hg bzr git cvs
0

Check the output of functions. I'm pretty sure it contains a special function called precmd or chpwd which sets your PS1. See 9.3.1 of http://zsh.sourceforge.net/Doc/Release/Functions.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.