0

I have an Acer CB5-311 Chromebook 13 and would like to boot from an USB with Linux. I started by trying the short tutorial in this video. But the very last step fails, Ctrl+L just issues a dual beep in the scary screen and no boot options are shown.

I then tried following the tutorial to boot Chrubuntu from a USB stick. But I am getting the famous "Broken pipe" error when running the install script.

What other options do I have to boot from a USB with the Acer CB5-311 Chromebook 13?

  • The original answer is semi working this is just an update for users, use the instructions on https://github.com/marcino239/chrubuntu-tegra, this is tested and working. – user147241 Dec 13 '15 at 5:59
1

Lately I installed Ubuntu to my CB5-311 using this script from GitHub. It will keep your local storage intact so you can switch to original ChromeOS whenever you want.

You can do following steps:

  1. Enable developer mode on your device.
  2. Download the script to your device.
  3. Plugin a USB flash drive.
  4. Execute the from a bash shell:

    sudo bash chrubuntu-tegra.sh default 14.04 /dev/sda
    

This will setup Ubuntu 14.04 to your flash and will reboot your device. You can then boot from USB using CtrlU. This script will also install NVidia drivers so you will be able to use cuda stuff as well(not tested yet).

One note about odd USB disk formatting used by the script. USB disk should be GPT partitioned with 2 partitions. I'm using the 'partitioned' intentionally; script formats all partitions in the USB disk in any case but disk should be partitioned prior to using script. Partitions should be 6 and 7, not 1 and 2 as one might expect normally. In order to achieve this, one may uncomment lines 42, 43, 44 and 47. If your chrome OS has 'cgpt' command, then it will work. Otherwise, another Linux machine should be used for partitioning USB disk.

  • When I run the script I get this error: "Terget Kernel Partition: /dev/sda6 Target Root FS: /dev/sda7 mke2fs 1.42.12 (29-Aug-2014) The file /dev/sda7 does not exist and no size was specified." – Luís de Sousa Nov 3 '15 at 13:06
  • Your USB disk is not well formatted probably, maybe you can try un-commenting lines 42,43,44 and 47. – Caglar AKYUZ Nov 3 '15 at 13:11
  • I'll try that. In the meantime, how should the disk be formatted? Perhaps this is something you can add to your answer. – Luís de Sousa Nov 3 '15 at 13:46
  • I added further explanation for the formatting to my answer. – Caglar AKYUZ Nov 3 '15 at 13:58
  • With these lines uncommented I get this: "ERROR: invalid argument to -s: "-l". This seems to be an issue with line 44, but I have no idea how to fix it. – Luís de Sousa Nov 3 '15 at 13:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.