2

I have put a fresh install of Debian 7.9.0 on an ASRock IMB-150 mainboard and only 4 of the 5 on-board serial ports seem to be enabled.

root@myhost:~# dmesg | grep tty
[    0.000000] console [tty0] enabled
[    1.476855] serial8250: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
[    1.497885] serial8250: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
[    1.518912] serial8250: ttyS2 at I/O 0x3e8 (irq = 4) is a 16550A
[    1.539944] serial8250: ttyS3 at I/O 0x2e8 (irq = 3) is a 16550A
[    1.561202] 00:07: ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
[    1.604531] 00:08: ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
[    1.648446] 00:09: ttyS2 at I/O 0x3e8 (irq = 7) is a 16550A
[    1.688367] 00:0a: ttyS3 at I/O 0x2e8 (irq = 7) is a 16550A
root@myhost:~#

I also installed setserial and get this information from it:

root@myhost:/# setserial -g /dev/ttyS*
/dev/ttyS0, UART: 16550A, Port: 0x03f8, IRQ: 4
/dev/ttyS1, UART: 16550A, Port: 0x02f8, IRQ: 3
/dev/ttyS2, UART: 16550A, Port: 0x03e8, IRQ: 7
/dev/ttyS3, UART: 16550A, Port: 0x02e8, IRQ: 7
root@myhost:/#

I undersatand this is because Debian 7 only detects a maximum of four ports by default. I have followed the instructions I found here, editing the grub file but this seems to have had no effect. Perhaps these instructions apply to a different version of Debian or Ubuntu only.

Can anyone tell me how to enable the fifth serial port?

Thanks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.