3

I've seen a lot of tutorials on how to crack a WPA/WPA2 Network using Reaver or Aircrack-Ng on Kali Linux. However, neither of these tools work for me.

With Reaver, after it switches to the correct channel (after a decent amount of time switching between channels), it just freezes and doesn't output anything, even with -vv as an option. With the Aircrack-Ng method, I never see a WPA handshake after sending a deauth package.

If this isn't the right place to ask about this, where should I ask for help on this? If this is the right place, what can I do about this?

Here is a picture from my iPhone that shows what pops up in my virtual console 1 after booting up. Everything above the part for entering the login shows up during boot, everything after that shows up after boot.

Picture of Virtual Console 1 After Booting

I don't know if this has anything to do with it, but it may. Regardless, does this pose any problem for my Kali Linux? I am running Kali Linux 2.0 on an ext4 partition.

If the installation process of Kali Linux makes a difference, it is contained in my post here: Warning while Booting into Ubuntu. This post of mine contains the warnings I get while booting into Ubuntu, which are similar to that of booting into Kali Linux.

So I guess I have two questions:

  1. Where can I get help using tools like Reaver or Aircrack-ng?
  2. Are the warnings in the image anything I need to worry about?

EDIT:

Here is information requested about the errors:

For the ext4 one, my installation completed successfully. It ended saying that I could reboot into Kali now. However, if you look in the link I provided, it shows about my installation procedure, and there were some parts that I believe were not that significant that I could not see any options for, as part of the installer was cut off on my display, but I'm not sure if that was the problem.

My Wifi connection works fine, as I am posting from Kali Linux. However, I can just try sudo apt-get <app> if I must. I don't know what the name is for the iwlwifi firmware.

I just tried running the command regarding the openvas-scanner, and then with the -l option, which it said to show extra information, and this is the output:

sudo systemctl status openvas-scanner.service -l
● openvas-scanner.service - Open Vulnerability Assessment System Scanner Daemon
   Loaded: loaded (/lib/systemd/system/openvas-scanner.service; enabled)
   Active: failed (Result: exit-code) since Sun 2015-10-18 20:08:25 PDT; 21h ago
     Docs: man:openvassd(8)
           http://www.openvas.org/
  Process: 742 ExecStart=/usr/sbin/openvassd --listen=127.0.0.1 --port=9391 (code=exited, status=1/FAILURE)

Oct 18 20:08:25 kali systemd[1]: openvas-scanner.service: control process exited, code=exited status=1
Oct 18 20:08:25 kali systemd[1]: Failed to start Open Vulnerability Assessment System Scanner Daemon.
Oct 18 20:08:25 kali systemd[1]: Unit openvas-scanner.service entered failed state.

EDIT

If it makes a difference, my Kali Linux is on a logical ext4 partition. I also installed Kali grub the second time going through, which is what is run now instead of my Ubuntu grub.

This is the output from lsusb:

Bus 001 Device 004: ID 0a5c:5801 Broadcom Corp. BCM5880 Secure Applications Processor with fingerprint swipe sensor
Bus 001 Device 003: ID 8087:07dc Intel Corp. 
Bus 001 Device 002: ID 8087:8000 Intel Corp. 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 002: ID 1bcf:2985 Sunplus Innovation Technology Inc. Laptop Integrated Webcam HD
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

And the output from lspci:

00:00.0 Host bridge: Intel Corporation Haswell-ULT DRAM Controller (rev 0b)
00:02.0 VGA compatible controller: Intel Corporation Haswell-ULT Integrated Graphics Controller (rev 0b)
00:03.0 Audio device: Intel Corporation Haswell-ULT HD Audio Controller (rev 0b)
00:14.0 USB controller: Intel Corporation 8 Series USB xHCI HC (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series HECI #0 (rev 04)
00:16.3 Serial controller: Intel Corporation 8 Series HECI KT (rev 04)
00:19.0 Ethernet controller: Intel Corporation Ethernet Connection I218-LM (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series HD Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 1 (rev e4)
00:1c.3 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 4 (rev e4)
00:1c.4 PCI bridge: Intel Corporation 8 Series PCI Express Root Port 5 (rev e4)
00:1d.0 USB controller: Intel Corporation 8 Series USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation 8 Series LPC Controller (rev 04)
00:1f.2 RAID bus controller: Intel Corporation 82801 Mobile SATA Controller [RAID mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series SMBus Controller (rev 04)
02:00.0 Network controller: Intel Corporation Wireless 7260 (rev 73)
03:00.0 SD Host controller: O2 Micro, Inc. SD/MMC Card Reader Controller (rev 01)

I apologize if this is in a difficult-to-understand format.

1

There are some pretty serious issues highlighted in that screenshot.

  1. mmc0: Unknown controller - this one is probably nothing to worry about
  2. fsck: error 2 (No such file or directory) ... fsck.ext4 - you're missing at least some of the system utilities for managing ext4 filesystems. Did the installation complete successfully?
  3. iwlwifi ... firmware: failed to load iwlwifi-7260-12.uc - your WiFi firmware isn't installed so the card will neither be initialised nor available for use. You need to install the missing firmware from the repository.
  4. failed to start Open Vulnerability Assessment System Scanner Daemon. See 'systemctl status openvas-scanner.service' for details - have you run the command it tells you to run, to review the problem?

You really need to address these issues before trying to move on further.


When you don't know the name of a package there is a very useful command called apt-cache that can help you find it. From there it can be installed in the usual manner.

apt-cache search iwlwifi
firmware-iwlwifi - Binary firmware for Intel Wireless cards

apt-get install firmware-iwlwifi

Personally, for my Debian systems I prefer the interactive mode of aptitude. (Run the program, then / is the search key, so /iwlwifi, and then + to mark for install and g to go and apply the changes.)


It seems that Kali uses an older version of the iwlwifi package that doesn't support your 7260 WiFi card. If you follow through the answer from smoortema for No wireless for Intel Corporation 7260 version 63 over on Ask Ubuntu you should find it works for you too.

  • Anything about the last part (The CPU pipe A FIFO underrun)? I added information about the others to my question. – Rohan Oct 20 '15 at 0:33
  • It says firmware-iwlwifi is the newest version. I tried apt-get install firmware-iwlwifi. No good. Then I tried apt-get --reinstall install firmware-iwlwifi. Boot errors still persist. I also tried apt-get --reinstall install openvas-scanner (which is probably causing the reaver issues). The errors still didn't go away during boot. I don't exactly know what to do. i am also getting errors when booting up into my other OS, Ubuntu. Would the best option be to erase both OS's and start fresh? I don't have much, it won't be too difficult a change. However, if I can fix it, I would like to try. – Rohan Oct 20 '15 at 17:55
  • @Rohan are you really running an IWL wifi card? Output of lsusb or lspci will have a line for the WiFi device. please can you add that info to your question. Better, also check that the card has the right driver :) – roaima Oct 20 '15 at 18:04
  • I'm sorry but I am really not that tech savvy. How do I check the card has the right driver? I would really appreciate it if you could give me instructions/commands for all of these things. I'm still learning computers :) I will check what WiFi device I have. – Rohan Oct 20 '15 at 19:26
  • @Rohan run the two commands I gave you in the above comment. Paste (please don't screen shot if you can avoid it) the output into your question – roaima Oct 20 '15 at 21:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.