3

I have trouble in connecting lftp with ftps (ftp over ssl, not sftp!) server (FTP Server Ultimate (PRO version).) running on Android phone.

Technical details:

Linux part. Following : https://superuser.com/questions/623236/simple-command-to-connect-to-ftps-server-on-linux-command-line I’ve created following lftp_config file and source it in following way:

$ cat lftps_config 
user photos PASSWORD
set ftps:initial-prot "";
set ftp:ssl-force true;
set ftp:ssl-protect-data true;
set ssl:verify-certificate no;
open ftps://192.168.1.103:43210
$ lftp
lftp :~> source lftps_config 
lftp 192.168.1.103:~> dir
ls at 0 [530 Login incorrect.]

while on “FTP Server Ultimate Pro” logs I see:

2015-10-18 10:10:13 [photosXYZ] - 192.168.1.123 (JBTTAX) - "" and *** are not allowed combination...
2015-10-18 10:10:13 [photosXYZ] - 192.168.1.123 (JBTTAX) New connection...

Could you help me how to setup FTP over SSL (ftps) connection on Linux using lftp (or other command-line tool with good mirror capability) ?

FTR, I use:

$ lftp -v | tail -n 1 Libraries used: Readline 6.3, Expat 2.1.0, GnuTLS 3.4.5, zlib 1.2.8

which according to documentation has FTPS capability (GnuTLS implies it).

For curious, more context:

My final goal: Have some directories automatically backed up (both, locally and remotely) from my Android phone to Linux workstation, laptop etc.

  • Android: FTPS server (ftp over ssl, not sftp!), starting automatically when I enter my home wifi, when away using DDNS (Dynamic DNS)
  • Linux: lftp (or other command line tool) that backs up stuff from phone - might be triggered by some cron-like automation that in presence of my phone ftps server would trigger automatic backup

Android part I (as least I thought, that I) solved with FTP Server Ultimate (to be specific PRO version). Server has capability of running FTPS server, and starting it automatically on given SSID or BSSID. When I am travelling it can update DDNS automatically, what makes reachability from my home servers easy.

3

You might try using:

set ftps:initial-prot P

Why? RFC 4217, which governs FTP over TLS, says that the PROT command, when used for TLS, really only has two values: C (Clear), or P (Protected).

Based on your log message containing:

"" and *** not allowed combination...

I'm guessing that the double quotation marks from from that ftps:initial-prot setting of "" in your lftp config.

2

I know this thread is somewhat old, but I ran into the same problem and in the end the following setting fixed it for me:

set ftp:ssl-protect-data true

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.