0

I have a USB with Elementary 3.01 (Freya). I am able to successfully run the liveCD (which I am in now) and am able to perform the install of the OS onto my PC. Upon what appears to be a successful install of the OS, I reboot and get the following:

Minimal BASH like line editing is supported. For the first word, TAB lists possible command completions. Anywhere else TAB lists possible device or file completions.

Now of course I have gone digging to see what the go is and it appears that this is a common issue. I can validate that the USB is formatted correctly as I have gone and installed the OS successfully on my old laptop.

I have read on AskUbuntu /questions/159846/tried-to-boot-ubuntu-but-the-grub-rescue-shows-up-instead and on Unix /questions/148041/recovering-from-grub-rescue-crash

But this has yet to help me. I am not attempting to dual boot the OS so I have used the automatic partitioning tool to create my drive. When I run the ls command from grub it gives me some error accessing (hd0), I cannot upload the image due to no PC, but will advise once I can.

Some key settings I am using on my Gigabyte Motherboard:

Windows 8 Feature has been set to Other OS and not Windows 8 or Windows 8 WHQL

Boot Mode selection has been set to Legacy and not UEFI or UEFI and Legacy

The Storage Boot Option Control has been set to Legacy First, not UEFI first

XCHI Mode has been set to Smart Auto and not auto, disabled or enabled

XCHI Handoff has been set to enable and not disable

EHCI Handoff has been set to disable and not enable

Due to not having an operational PC (that laptop is far too slow for use), there is little research I can do, as testing something requires me to down the machine for 10-25 minutes per try.

I could attempt to use another Linux Distro but that would mean re-downloading the .iso and then making a bootable USB. If this issue could be fixed I'd prefer to stick with it.

Update 1

From within Elementary OS on my laptop I installed unetbotin, ran as root and formatted my USB. I successfully installed the OS in UEFI mode and rebooted to get to the bash screen. I then followed these steps:

ls to identify (hd2,gpt2) which has the boot/ directory and vmlinuz folder.

set root=(hd2,gpt2)/boot was the next command ran.

isnmod linux followed by linux (hd2,gpt2)/boot/vmlinuz-3.19.0-26-generic (also tried the .efi one)

The next command was initrd (hd2,gpt2)/boot/initrd.img-3.19.0-26-generic and then boot and prompt was brought to initramfs, cool.

This successfully started BusyBox. From here the PC stopped recognizing my keyboard, even in BIOS/Legacy mode.

Update 2 I am sick of using the laptop. I have installed Ubuntu 15.04 via a Live CD. Upon reboot I get to the GRUB menu (which still has the entries for Elementary) but booting to UBUNTU fails. I enter advanced Ubuntu and boot to generic and all is well.

I cannot get to the settings for Display as it crashes and I cannot use the shortcut key Ctrl + Alt + T to launch terminal, but that's okay. I have installed Grub Repair and will boot to the live environment and run.

At the moment I am performing the standard updates to the system (which I hope are some bug fixes) and I will get the additional drivers. Once I have a somewhat operational Linux OS I will format the secondary SSD in my PC and try to install Elementary to that, at least having a fallback when it fails.

Update 3 Both Arch Linux and Manjaro linux result in a terminal with just _ on the screen with no input. I have also attempted to install Ubuntu 15.04 and Lubuntu 15.04 but fail due to some weird USB 1-10 fail to read -71error. I am now starting to think either there is some major hardware clash or it's the operator.

I am going to download Mint and Sabayon to see what I can do.

  • To help identify if this is an OS specific issue, I am going to attempt to download Manjaro and use dd to format a USB. If that install works I will be able to identify if it an issue with this OS, or more a setting on my BIOS/MoBo. – DankyNanky Oct 18 '15 at 2:11
  • Within Elementsary I have downloaded Arch, Manjaro, Elementary and Mint. I have used unetbootin to format the elementary install and will try again. The steps I go through will be posted in the question. – DankyNanky Oct 18 '15 at 4:29
0

Following the steps of Update 2 did not help, but once another GRUB menu was present, I was able to boot into the OS.

This is not the technical fix to this fault, however this was my fix.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.