1

I am currently using Zsh + Prezto for my scripting shell configuration. I have been using the sorin theme but am a little dissatisfied with it. I'd like to switch to the paradox theme!

It is supposed to look like this:

Blockquote

I'm having some trouble doing that. When I switch to the theme, the symbols aren't able to load, so I get a prompt that looks like this:

Blockquote

Notice the boxed question marks where there should be an edge border for the background or a branch symbol for the git branch. (Take a look at the paradox theme preview here).

I've seen here that I should install Powerline patched fonts for the symbols to load in correctly. However, as I'm somewhat unfamiliar with the process, I would love some help installing it into my Linux machine.

In the documentation, it notes I should install via pip. When I run pip install --user powerline-status, my prompt is still unable to display the symbols the way it should look.

What else must I do, after running the installation, to display this prompt correctly?

I am using a MacBook Pro with El Capitan

3

I've just done it for myself, do the following :

Run ./install.sh to install all Powerline Fonts then go to your terminal prefences, change the non-ascii fonts by 'Anonymous Pro'.

Reload your terminal to be sure changes are acknowledged by your system, then just try this command : echo "\ue0b0 \u00b1 \ue0a0 \u27a6 \u2718 \u26a1 \u2699", you should get the following : enter image description here

Enjoy your new prompt

  • I have a similar issue, the arrows are not appearing. Can you tell me where you run the install.sh and where to find Anonymous Pro (I couldn't find it in my iterm) – AKFourSeven Jan 5 '16 at 14:06
  • Ok I managed to find out the answers, by downloading the powerline font on github (github.com/powerline/fonts) you then run the sh and proceed as you said and everything works like a charm, thnak you!! – AKFourSeven Jan 5 '16 at 14:48
  • Glad to hear your issue is solved, please upvote my answer if it helped you ;) – malikba Jan 5 '16 at 17:10
  • yep forgot to do that sorry !! – AKFourSeven Jan 6 '16 at 9:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.