0

I have a dell precision m6800 laptop that is experiencing stubborn low screen resolution problems with red hat 7. The funny thing is I installed RH 7 with no BIOS raid configured and I got the expected 1920x1080 resolution. Then I turned RAID on, reinstalled from scratch and am stuck at 1024x768. who would think those two things would be even remotely connected?

Anyway, I've done some research and ran some commands to find out my driver situation (it seems I am running Nvidia drivers), and I thought that installing and running nvidia-settings to probe the hardware and sync that with the X settings would be a good idea. I read up on Xconfigurator, but that seems to be available only for XFree86, not Xorg X servers. Something like that for Xorg servers would be nice to have if you know of it! Anyway, nvidia-settings failed to install and now I am stuck on what to do next.

I've reproduced the output of the relevant commands that I have run below:

/home/chris/reso > sudo find /dev -group video
/dev/video0
/home/chris/reso > glxinfo | grep -i vendor
server glx vendor string: SGI
client glx vendor string: Mesa Project and SGI
OpenGL vendor string: VMware, Inc.


lspci -k 
01:00.0 VGA compatible controller: NVIDIA Corporation GK104GLM [Quadro K5100M] (rev a1)
        Subsystem: Dell Device 05cd


/home/chris/reso > sudo lspci | grep VGA ; lsmod | grep "kms\|drm" ; find /dev -group video ; cat /proc/cmdline ; find /etc/modprobe.d/;  ls /etc/X11/xorg.conf ; glxinfo | grep -i "vendor\|rendering" ; grep LoadModule /var/log/Xorg.0.log
01:00.0 VGA compatible controller: NVIDIA Corporation GK104GLM [Quadro K5100M] (rev a1)
drm_kms_helper         98226  1 nouveau
drm                   311588  3 ttm,drm_kms_helper,nouveau
i2c_core               40325  7 drm,i2c_i801,i2c_hid,drm_kms_helper,i2c_algo_bit,nouveau,videodev
/dev/video0
find: ‘/dev/vboxusb’: Permission denied
BOOT_IMAGE=/vmlinuz-3.10.0-229.14.1.el7.x86_64 root=/dev/mapper/rhel-root ro rd.md.uuid=1c61b17f:a14cde73:84cd857e:ceb07a0d nomodeset rd.lvm.lv=rhel/root rd.lvm.lv=rhel/swap crashkernel=auto rd.md.uuid=bb7b14f3:039bf6a4:367d16b4:e0c9f858 rhgb quiet LANG=en_US.UTF-8 systemd.debug
/etc/modprobe.d/
/etc/modprobe.d/mlx4.conf
ls: cannot access /etc/X11/xorg.conf: No such file or directory
direct rendering: Yes
server glx vendor string: SGI
client glx vendor string: Mesa Project and SGI
OpenGL vendor string: VMware, Inc.
[     4.950] (II) LoadModule: "dri2"
[     4.950] (II) LoadModule: "glamoregl"
[     4.951] (II) LoadModule: "glx"
[     4.952] (II) LoadModule: "nouveau"
[     4.952] (II) LoadModule: "modesetting"
[     4.952] (II) LoadModule: "fbdev"
[     4.952] (II) LoadModule: "vesa"
[     4.959] (II) LoadModule: "fbdevhw"
[     4.959] (II) LoadModule: "fbdevhw"
[     4.960] (II) LoadModule: "vbe"
[     4.960] (II) LoadModule: "int10"
[     5.124] (II) LoadModule: "ddc"
[     5.324] (II) LoadModule: "shadow"
[     5.324] (II) LoadModule: "fb"
[     5.325] (II) LoadModule: "int10"
[     5.537] (II) LoadModule: "evdev"
[     5.557] (II) LoadModule: "synaptics"

Finally, here is the output of /var/log/Xorg.0.log, which might be relevant. I'm linking to it since it is long. There was also a /var/log/Xorg.9.log with almost identical content, which I won't bore you with for now.

Any ideas or tips most appreciated.

  • You should install the Nvidia drivers. It seems you use a strange mixture: the driver used is vesa (maybe nouveau doesn't work for your card) and opengl uses vmware. – cylgalad Oct 17 '15 at 9:06
  • According to the Xorg.0.log [ 4.959] (EE) [drm] KMS not enabled there is a problem with the kernel mode setting. Since KMS is needed for the nouveau driver, X falls back to using the vesa driver. – Thomas Weinbrenner Oct 17 '15 at 9:17
  • thank you, gentelmen - yes.. it seems the problem was nouveau drivers were interfering with Nvidia drivers. I needed to blacklist the nouveau drivers via /etc/modprobe.d/blacklist.conf.. then i downloaded the nvidia drivers and installed manually. then i used nvidia-settings and all went well. – Chris Bedford Oct 18 '15 at 20:01
  • correction/clarification to above comment. I couldn't have done this without the help of my friend Matt @ mattcurry.com -- awesome linux dude. – Chris Bedford Oct 19 '15 at 0:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.