2

I'm trying to install arch linux alongside windows 10 and have created a separate partition in (while running) windows as exFAT32. While booting from the arch USB image and running lsblk the following output is given (sda is a single physical drive):

lsblk

sda5 contains the actual windows installation while sda6 contains the new partition in which I want to install arch:

enter image description here

Following the installation guide here it is suggested that the boot installation medium is checked:

# ls /sys/firmware/efi/efivars

In my case there is no such file/directory. UEFI is disabled and the device is using the legacy booting mechanism. However, when running

fdisk -l

the following output is shown: fdisk -l

suggesting that sda is of type gpt. Following the guide, when trying to create a partition table with:

# parted /dev/sda6
(parted) mklabel msdos

or

# parted /dev/sda6
(parted) mklabel gpt

the following error is thrown:

Error: Partition(s) 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17,
18, 19, 20, 21, 22, 23, 24, 25, 26, 27, 28, 29, 30, 31, 32, 33, 34, 35, 36, 37,
38, 39, 40, 41, 42, 43, 44, 45, 46, 47, 48, 49, 50, 51, 52, 53, 54, 55, 56, 57,
58, 59, 60, 61, 62, 63, 64 on /dev/sdb1 have been written, but we have been
unable to inform the kernel of the change, probably because it/they are in use.
As a result, the old partition(s) will remain in use.  You should reboot now
before making further changes.

Reading the answer of this question the partition table should be created on the disk on which it belongs to, not the partition itself. The problem is that parted warns about formatting /dev/sda entirely (meaning that the windows installation will be removed as well).

Another issue would be that it is not possible to set the new partition (/dev/sda6) as bootable:

unbootable

  • I can't figure out what you're having trouble with. As you've noted, parted /dev/sda6 is wrong, because the partition table is not inside the partition. So what's the problem when you run /dev/sda? – Gilles Oct 17 '15 at 20:12
  • I'm prompted that the /dev/sda is going to be formatted (including /dev/sda5 where the windows partition is located on that I want to spare). – Sebi Oct 18 '15 at 9:18
  • So don't format it, just work on the partition that you want to change (it's not clear to me what change you're trying to make — maybe you should rewrite the question to what you want to achieve, rather than the possibly unsuited method that you tried). – Gilles Oct 18 '15 at 12:01
  • I want to install arch on /dev/sda6 without formatting /dev/sda5 or the other partitions of /dev/sda except /dev/sda6 to one in which I want my installation. – Sebi Oct 18 '15 at 12:05
1

Rewritting a partition table (e.g. changing its type) will trigger the removal and re-creation of all partitions in the device... thus losing absolutely everything there.

If you partitioned the device from Windows, it looks like Windows did some tricky stuff with the data in the disk (see the output of fdisk: "Microsoft basic data" (??)

Try just reformatting the partitions before to your desired filesystem from Linux and then try again setting the boot flag in the partition once you have installed archLinux in there.

Anyway, whenever I want to prepare a system for dual-boot Windows & Linux, I prepare the partitions before and from a Linux Live image, so that Windows never puts its "paws" in the other partitions destined to host the root filesystem of my Linux.

  • +1 The problem is that I bought the notebook with windows 10 and wouldn't want to loose it as it's been paid for. The problem is that I cannot seem to be able to install anything on that partition. – Sebi Oct 16 '15 at 22:28
  • @Sebi Quite understandable (to keep what you paid for ;) ). But did you created the extra partitions (...in windows or linux?) or were they already created? – dave_alcarin Oct 16 '15 at 22:30
  • The one I'm trying to install arch to was created in windows by shrinking the main partition (Volume C where windows has been installed to) since there wasn't enough space on the drive. There was only one partition initially with which windows was shipped with. The ones " "Microsoft basic data" were created by shrinking the main volume C and formatting the freed space as exFAT32. – Sebi Oct 16 '15 at 22:37
  • Then, as I said in my answer, try reformatting them from Linux, use some ext filesystem, for example, and see if you can continue – dave_alcarin Oct 16 '15 at 22:41
  • I tried it with ext4 and it still gives the same errors (cannot create a bootable partition and also no partition table). – Sebi Oct 16 '15 at 22:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.