0

I have had a problem with this old PC since I got it, it's a very early 2000's Dell PC. I'm talking 512mb of RAM, THAT old. It had Windows XP on it, which I wiped and replaced with Kali Linux 1.1.0, 32-bit. This computer happens to be SO old that it has only eth0 and lo interfaces. Since there are no ethernet cables except on our wifi router, I bought a Realtek wifi adapter (in case anyone happens to be advanced in Realtek adapters, it is the RTL 8192 model). After a lot of messing around, I managed to run the driver install.sh, and I am almost certain it worked correctly. I would be completely sure, except when I ran the wpa_supplicant install and the hostapd install, they both exited after only printing their respective config file information, stating that they could not initialise the wlan0 interface (which is what it should be installing). Reading the manual, I noticed that it said that I should copy the supplicant/hostapd to 'the target platform', which I assumed just meant in the same folder. But given that neither are working, I am not sure what target platform means now, and I was wondering if it was critical... and if so, where I should be copying to. If the target platform means nothing, tell me and I will post another question with details from the failed installs. Thanks in advance

EDIT:

My guesses are:

a) Anywhere on the computer, which would mean nothing

b) Root directory

c) In the kernel modules folder, perhaps in the folder containing the wifi driver

Either way, here is what the Manual says, bold is what I have done successfully:

(1) wpa_supplicant

(1-1)unzip wpa_supplicant_hostapd-0.8_rtw_20111118.zip

(1-2)cd wpa_supplicant_hostapd-0.8\wpa_supplicant

(1-3) vim Makefile

add:

CC = mipsel-linux-gcc

(1-4)make

(1-5)copy "wpa_supplicant" and "wpa_cli" to target platform

(1-6)copy "wpa_0_8.conf" file to target platform

(1-7)./wpa_supplicant -iwlan0 -Dwext -c wpa_0_8.conf -dd &

(1-8)./wps_cli (for wps in Interactive mode)

(1-9) > help

wps_pbc

wps_pin any 12345678

(2) hostapd

(1-1)unzip wpa_supplicant_hostapd-0.8_rtw_20111118.zip

(1-2)cd wpa_supplicant_hostapd-0.8\hostapd

(1-3) vim Makefile

add:

CC = mipsel-linux-gcc

(1-4)make

(1-5)copy "hostapd" and "hostapd_cli" to target platform

(1-6)copy "rtl_hostapd.conf" file to target platform

(1-7)start hostapd daemon:

./hostapd rtl_hostapd.conf -B

0

"Target platform" is the CPU architecture and operating system you're (cross)compiling things for.

The setting

CC=mipsel-linux-gcc

means you're about to compile stuff for some platform that runs Linux on a MIPS processor. That would typically be one of the "hackable" router models on the market with a router-specific Linux distro installed (Tomato Router or similar), not a PC. It looks like the "manual" you're reading is not for the general use case.

You need hostapd only if you're setting up the system as a WLAN access point, i.e. to provide a wireless network for other hosts. If you only want to use a wireless network, wpa_supplicant is the software you need.

The driver should always provide the network device: both hostapd and wpa_supplicant only manage the wireless network configuration and authentication on it.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.