0

I installed the latest Qt version (5.5.1), and Qt creator worked fine, I could build programs with it.

However, after I installed cmake, downloaded opencv from source, and built it, Qt creator no longer works. It silently crashes on startup, and if I start it from the console, it just says "Segmentation fault", nothing more.

I didn't put cmake and opencv in the title of this question, because I'm not sure if they are really the culprits. The following happened after I successfully used Qt:

  • I tried to install a Radeon driver to use a second screen, by following https://wiki.debian.org/ATIProprietary , but it didn't work. (the installation was apparently successful, but my secondary video card is still not detected)

  • I installed cmake, together with its gui (called cmake-gui)

  • I downloaded the opencv source, and successfully built it, by specifying the 5.5.1 Qt folders as the location of Qt

  • During all of the above, one update was performed on the system. (apt-get update and apt-get upgrade)

I'm suspecting cmake, because its gui uses Qt4, so it might have installed some stuff from Qt4 which might be causing conflicts - however, it seems that Qt4 was already installed with KDE, because I've seen it in the "software management".

I tried deleting and installing Qt5.5.1 again, with no effect.

I'm using KDE, and I cannot even uninstall Qt5.5.1 properly. It doesn't appear in the Software management - System settings, and when I right-click on its shortcut in the "start menu", I get the option to uninstall, but I'm greeted with The file could not be found in any installed package - so apparently my system doesn't seem to see Qt at all. (I can't even find any way to remove the shortcut, or even find where the executable is by right clicking, I had to locate the application manually - either there are serious UX issues, or I'm not experienced enough with the UI of KDE)

I'm using debian 8 (jessie)

0

It seems the problem was caused by the failed installation of the graphic drivers. As Qt creator uses OpenGL for some of the animations, it couldn't start.

Reinstalling xserver solved the issue. I still can't use the second screen, but at least Qt works again.

Check this link for a detailed description of this situation: https://bugreports.qt.io/browse/QTBUG-34109

sudo apt-get purge nvidia*

# For 32-bit,
# sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx:i386 libgl1-mesa-dri:i386

# For 64-bit
sudo apt-get install --reinstall xserver-xorg-core libgl1-mesa-glx:amd64 libgl1-mesa-dri:amd64

sudo dpkg-reconfigure xserver-xorg

reboot

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.