2

Recently I decided to switch from Ubuntu to OpenSuse so normally I attained the TumbleWeed image from OpenSuse and began installing it.

The installation process finished without any problem but after I rebooted to enter my newly installed distro I encountered a blank black screen. (GRUB is not loaded)

After much inquiring I managed to boot into Gnome using the installation disk's Boot installed system feature but whenever I reboot the same thing happens.

I tried re-installing GRUB using this guide but it did not work.

Since I had my /home and /opt on separate partitions than / I skipped formatting them and just formatted the root partition.

Here is what fdisk -l spurts out:

Disk /dev/sda: 119.2 GiB, 128035676160 bytes, 250069680 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: gpt
Disk identifier: A7177FCC-43B2-42CE-92AD-B35D979E2CCB

Device         Start       End  Sectors  Size Type
/dev/sda1       2048  58593279 58591232   28G Linux filesystem
/dev/sda2   58593280  68358143  9764864  4.7G Linux filesystem
/dev/sda3   68358144 126951423 58593280   28G Linux filesystem
/dev/sda4  126951424 129067007  2115584    1G Microsoft basic data
/dev/sda5  129067008 145838079 16771072    8G Linux filesystem


Disk /dev/sdb: 931.5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: dos
Disk identifier: 0xee81add0

Device     Boot     Start        End    Sectors   Size Id Type
/dev/sdb1  *         2048     718847     716800   350M  7 HPFS/NTFS/exFAT
/dev/sdb2          718848  419432447  418713600 199.7G  7 HPFS/NTFS/exFAT
/dev/sdb3       419432448 1953521663 1534089216 731.5G  7 HPFS/NTFS/exFAT


Disk /dev/sdc: 15 GiB, 16039018496 bytes, 31326208 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x19aca6bd

Device     Boot Start     End Sectors  Size Id Type
/dev/sdc1        3688   11247    7560  3.7M ef EFI (FAT-12/16/32)
/dev/sdc2  *    11248 9095167 9083920  4.3G 17 Hidden HPFS/NTFS

As you can see I have 2 HDDs (my primary being an SSD disk).

Upon installation I used the following partition table:

/dev/sda1 mounted on /
/dev/sda2 mounted on /opt
/dev/sda3 mounted on /home
/dev/sda4 (fat) mounted on /boot/efi
/dev/sda5 mounted on swap
/dev/sda6 unpartitioned

So here I am stuck at that black screen. I tried to be as much detailed as possible so if anyone could help me I'd be immensely grateful.

1

I finally managed to fix the issue and here are the steps I took in case someone else faced the same problem.

First you need to boot into your installation by either using Installation Disk or using the live version. It's done by entering the installation section of installer and then clicking Abort and then inside the blue screen following the Installation --> Boot installed system to get into your system.

After that you need to open up Settings and then going into Yast setting page. Finally by clicking Boot Loader you can install GRUB2 on to your MBR.

After that the GRUB screen will load.

I faced another issue which upon selecting OpenSuse in grub there were 2 errors indicating that linuxefi and initrdefi command can not be found.

It is fixed by booting in Rescue Mode and and mounting your root partition and editing /boot/grub2/grub.cfg and replacing every instance of linuxefi and initrdefi by their non efi equivalent which respectively are linux and initrd.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.