2

Whenever I try to build fglrx with dkms for kernel 3.18.22 I get the following:

FATAL: modpost: GPL-incompatible module fglrx.ko uses GPL-only symbol 'pci_ignore_hotplug'
scripts/Makefile.modpost:90: recipe for target '__modpost' failed
make[2]: *** [__modpost] Error 1
Makefile:1384: recipe for target 'modules' failed
make[1]: *** [modules] Error 2
make[1]: Leaving directory '/usr/src/linux-3.18.22'
Makefile:88: recipe for target 'kmod_build' failed
make: *** [kmod_build] Error 2
build failed with return value 2

How can I fix this? I've looked around online but haven't found a whole lot on it.

My distro is Debian 8 Jessie, I'm using sudo dkms autoinstall -k 3.18.22 to build and I'm using the official drivers straight from AMD's site.

EDIT: So I tried compiling 4.2.3 which didn't work as I suspected since AMD doesn't even claim to support that kernel but I also tried 3.14.54 which like 3.18.22 is an LTS kernel supported by the drivers. 3.14.54 worked just fine except it's older than the kernel Jessie ships with so it's kinda pointless. I guess it is just a matter of 3.18.22 not being supported. It's just weird because it's supposed to be.

  • This type of error usually means the sources aren't suitable for the kernel version, i.e. downgrade the kernel first. Check the fglrx docs for what kernel versions are supported. – wurtel Oct 16 '15 at 13:57
  • @wurtel According to AMD anything up to 3.19. There is a low end of 2.6 or something but that's not the issue – Scoopta Oct 16 '15 at 19:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.