3

Recently (say within the last two months), some of my media keys have ceased to obey their assigned shortcut.

Take, for example, Play. If I assign AudioPlay as the keyboard binding in the Keyboard->Keyboard Shortcuts menu, nothing happens when I press the key (this at least suggests that the the key is still recognized).

Further, if I assign another shortcut (e.g., Ctrl-Alt-slash), this works as expected, which suggests it is still possible to assign a shortcut to the play function.

This seems to be related to this question over on AskUbuntu, but the accepted solution (mess around with gsettings) does not apply, as the suspected lack of XF86 is not true in my case (at least in gsettings).

It may be worth noting that there is a discrepancy along these lines in my Keyboard Shortcut interface--namely, the media keys that still work (e.g., Mute) list the XF86 prefix in the shortcut menu, while those that don't work, don't have this prefix in this menu.

I've exhausted all other avenues of exploration that came to mind, including the suggested cinnamon-desktop-migrate-mediakeys which came along with the 17.1 release (this problem started well after I upgraded to 17.1).

Any other ideas?

  • Excellent - this was exactly my problem. Google Play Music chrome extension had hijacked the keys. I deleted the extension (didn't really need it after all) and everything is back to normal. Thanks! – Todd Tyrtle Aug 13 '18 at 16:02
4

It is very possible that you have a Chrome extension hijacking those keys -- for example, Plex or Google Play.

To investigate, head over to chrome://extensions/, and check out the "Keyboard shortcuts" link at the bottom of the page -- investigate to see which keys may be prioritized by Chrome extensions, e.g.:

plex hijacker

Here, it's clear to see that Plex has taken control of the Media Play/Pause, Media Next Track, Media Previous Track, and Media Stop buttons. Simply click the X next to each to un-set that shortcut entirely, or reset the scope to In Chrome if you'd still like those shortcuts to work while a Chrome window is activated. An alternative is to just turn off the extension itself.

The following links helped with this answer: http://www.makeuseof.com/tag/stop-chrome-hijacking-media-keys-heres/, http://www.omgchrome.com/chrome-google-music-media-keys/

  • Hmm. Plex is no longer hijacking, but the keys stopped working all of a sudden again. Maybe there's a way to query which program is hijacking the keys? – MichaelChirico Dec 13 '16 at 1:31
  • Just restarted and I have control back, even after starting Chrome. The mystery continues. – MichaelChirico Dec 13 '16 at 1:35
  • 1
    The "Keyboard shortcuts" option is now in the Extensions menu in newer versions of Chrome. – Zackary Dec 3 '18 at 20:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.