1

I have a external drive mounted to /media/usbhdd, the owner is: debian-transmission and the group is gebruikers.

In the group gebruikers i have added the person debian-transmission and pi. But when i want to change or delete something as user pi it doesn't work (i get an permission error).

my /etc/fstab looks like this:

/dev/sda1   /media/usbhdd  vfat  uid=debian-transmission,gid=gebruikers 0 0

With the command id pi i get this:

uid=1000(pi) gid=1000(pi) groups=1000(pi),4(adm),20(dialout),24(cdrom),27(sudo),29(audio),44(video),46(plugdev),60(games),100(users),101(input),108(netdev),999(spi),998(i2c),997(gpio),115(debian-transmission),1002(gebruikers)

And with the command ls -l /media/usbhdd: total 192

drwxr-xr-x 2 debian-transmission gebruikers 32768 Aug 30  2014 disk1
drwxr-xr-x 3 debian-transmission gebruikers 32768 Oct 14 11:42 Network Trash Folder
drwxr-xr-x 2 debian-transmission gebruikers 32768 Aug 31  2014 shares
drwxr-xr-x 3 debian-transmission gebruikers 32768 Oct 14 11:42 Temporary Items
drwxr-xr-x 4 debian-transmission gebruikers 32768 Oct 14 12:26 series
drwxr-xr-x 3 debian-transmission gebruikers 32768 Oct 14 12:26 movies 

How can i write/change/delete with user pi without changing uid in the fstab file?

EDIT This was the trick:

/dev/sda1 /media/usbhdd vfat uid=debian-transmission,gid=gebruikers,umask=0000 0 0

  • Could you edit your question to add what id pi prints? also an ls -l from some file or directory in /media/usbhdd would be useful to see what the driver sets as default rights. Anyway, plain fat file system maybe does not support everything (?) about unix-like permissions. I know vfat has no problems. – dave_alcarin Oct 14 '15 at 12:25
  • @dave_alcarin I have added the information, it is vfat it was my bad. – da1lbi3 Oct 14 '15 at 12:40
0

As you can see in the results of ls -l inside your device, the group and "others" permissions have the "write" flag cleared. Only the owning user may write.

If you want to keep the mounting ids intact, add a proper mode mount option in your /etc/fstab to enable write permissions to the group, for example mode=0775 is rwx for user and group, r-x for others.

  • is this the way to do it? /dev/sda1 /media/usbhdd vfat uid=debian-transmission,gid=gebruikers, mode=0775 0 0 – da1lbi3 Oct 14 '15 at 12:49
  • Scratch my previous comment. Remove the space after the comma. – dave_alcarin Oct 14 '15 at 12:52
  • The command doesn't work, when i reboot the root acount is locked.. if i remove the mode it boots up normally? – da1lbi3 Oct 14 '15 at 12:58
  • If it does not work, then remove the mode option and add the rw option, or set the umask completely to 0 – dave_alcarin Oct 14 '15 at 13:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.