2

I'm trying to install debian using the net installer. I arrived to the stage where I have to choose a mirror. I've tried several mirrors, and all of them resulted in a "Bad archive mirror" error. As I'm using the graphical installer, I used Ctrl+Left Alt+F2 to access the console and check whether my internet connection works.

Pinging an IP address (8.8.8.8) works. DNS apparently doesn't (google.com).

So I guess that the installer cannot find the mirrors, as they are all listed by their URIs.

Is there a possibility to give an IP address to the installer to use as a mirror? Or is it possible to (at least temporarily) set 8.8.8.8 as my DNS just for the purpose of downloading the necessary files for the install?

I'm halfway through the install process, and a lot of things don't work yet. I can't even access the manpages.

(Strangely, any device I connect to the LAN cable I'm using, works without a problem, I don't have to configure any network settings. Be it a Windows machine, Linux, or even an embedded Raspberry Pi, I just connect them and I can start browsing the web. So I don't know why the debian installer cannot find a working dns.)

2

The debian installer should either ask you for the name-server's IP address, or auto-discover it via DHCP.

If your DHCP server doesn't provide the name-server IP then:

  1. it's broken and should be fixed

  2. you can add it to /etc/resolv.conf yourself:

    echo "nameserver 8.8.8.8" > /etc/resolv.conf
    

You might want to cat /etc/resolv.conf to check its contents first.

If you have a local resolving name-server on your network (highly recommended) then use that rather than google's.

  • /etc/resolv.conf contains a local nameserver, 192.168.1.x, which seems to work with other machines on the network (amazingly, even with embedded systems). This also indicates that DHCP was detected. – vsz Oct 14 '15 at 9:20
  • I t seems the DNS was not the only problem. After adding 8.8.8.8, I can ping URIs, and some mirrors start downloading, so I no longer receive "bad archieve mirror". However, during configuring apt, file 4 of 7 I get "the installer failed to access the mirror". This happened with all mirrors I tried in several countries. A few still give the old (bad archive mirror) error. – vsz Oct 14 '15 at 9:29
  • Does your network have a local proxy (e.g. squid)? If so, you are given the opportunity to specify a proxy when selecting which mirror to use. – cas Oct 14 '15 at 9:39
  • I am given the opportunity, but I have no proxy as far as I know. I can plug in a completely foreign computer with a freshly installed OS and happily browse anything I want. – vsz Oct 14 '15 at 9:47
  • what kind of network controller do you have? lspci | grep -Ei 'eth|net'. – cas Oct 14 '15 at 9:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.