So I've installed Mint from a bootable USB. All seems to go well. However when I then go to boot into the install I'm greeted with a flashing cursor and nothing more.

After a bit of internet searching I came across the 'hold shift to force GRUB start', but that didn't do anything.

I checked the drive using gparted and there is definitely a boot partition on there.

Then I came across the boot-repair thing in this question which I ran. However it failed at the end saying there was still no GRUB present. The terminal output was:

The following packages have unmet dependencies:
  linux-signed-generic : Depends: linux-headers-generic (=     but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

I manually installed linux-headers-generic but I still get the same error.

So now I'm a bit lost as to what to do... Any suggestions?

The drive in question is a 120GB SSD Vertex 3, and it's in a Workstation computer with a Xeon chip and MoBo with a Asus GTX960 graphics card.

1 Answer 1


Alright. Found a solution. I had to change the SSD's access method or something from 'AHCI' to the 'compatible' setting. This fixed the problem.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .