1

Here's what I did:

I installed Debian by burning the first ISO from the repository to a USB. Booted from it, got Debian installed - except no desktop.

I tried using aptitude to get it, but I need a CD. So I installed my network adapter drivers (netgear wna1100, installed via usb as per Google of wna1100 Linux drivers) and tried to connect to the internet. Drivers seemingly installed fine with no errors, my network adapter is correctly identified in lsusb, but any command to connect to the internet relied on wlan0 which doesn't appear to exist. Nor does iwconfig...

How can I get a compete installation?

  • 1
    Using linuxcommando.blogspot.lu/2013/10/… as a guideline, please refine the data given about the exact circumstances and the errors encountered. Start with iw dev output. – Alex Stragies Oct 13 '15 at 19:57
  • Also, are you installing Debian Jessie or some other version? E.g., were you to be installing testing (Stretch), the device naming has changed, so it'd not be 'wlan0' – derobert Oct 13 '15 at 20:01
  • @derobert To my knowledge I am installing Jessie (8.2) or the stable version – lordnoob Oct 13 '15 at 20:15
  • @Alex Stragies /sbin/iw dev produces no output, but no 'unknown command' message either. Tried variations like just 'iw dev' to the same end. – lordnoob Oct 13 '15 at 20:16
  • Empty iw dev output means your driver is not loaded, you have the wrong driver, or need firmware installed/copied. Or device broken- It works on windows?. Please post relevant line from lsusb and lsmod. askubuntu.com/questions/216066/… may help. I think you need to install the firmware-atheros package. – Alex Stragies Oct 13 '15 at 20:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.