0

I am trying to run an executable on remote Linux through Putty (SSH).

When I run the executable on remote Linux through Putty I get the following error:

Exception in thread "main" java.lang.UnsatisfiedLinkError: /home/user/xhs/tps/lnx32/jre/lib/i386/libawt_xawt.so: libXi.so.6: cannot open shared object file: No such file or directory

If I execute apt-file search libXi.so.6 I get:

libxi6: /usr/lib/x86_64-linux-gnu/libXi.so.6
libxi6: /usr/lib/x86_64-linux-gnu/libXi.so.6.1.0
libxi6-dbg: /usr/lib/debug/usr/lib/x86_64-linux-gnu/libXi.so.6.1.0

Any idea? This did not help me

0

An important difference would be the arch:

jre/lib/i386/libawt_xawt.so
.../lib/x86_64...libXi.so.6

Which suggests that the 32-bit flavour of libXi.so.6 should be installed.

  • I installed libxtst6:i386 but did not work – Message Passing Oct 13 '15 at 15:51
  • What does "did not work" mean? ldd might be a good next step, or possibly strace to see where the application is looking for things. – thrig Oct 13 '15 at 18:43
  • It means that I installed libxtst6:i386 but I still get the same error. BTW, If I execute ldd xsetup I get not a dynamic executable. By executing sudo strace ./xsetup I get a very long output that I cannot paste in this answer because the forum says that it is too long. – Message Passing Oct 14 '15 at 7:03
  • The missing library error comes from libawt_xawt.so; what happened when you ran ldd on that? – thrig Oct 14 '15 at 15:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.