0

I have to install a program. When I run this command:

sudo ./Vivado-Hardware-Server/xsetup

I get the following error:

./Xilinx_HW_Server_Lin_2015.2_0626_1/xsetup: line 67: 
/home/user/Xilinx_HW_Server_Lin_2015.2_0626_1/tps/lnx32/jre/bin/java: No such file or directory

/home/user/Xilinx_HW_Server_Lin_2015.2_0626_1/tps/lnx32/jre/bin/java exists and its permissions are: -rwxr-xr-x

The OS is Ubuntu 64 bit and the Java version is:

java version "1.7.0_79"

OpenJDK Runtime Environment (IcedTea 2.5.6) (7u79-2.5.6-0ubuntu1.15.04.1)

OpenJDK 64-Bit Server VM (build 24.79-b02, mixed mode)

This and this did not help me. Any suggestion?

1 Answer 1

0

This error is most-probably caused by a missing shared-object (dynamic library). Try running ldd on the binary the xsetup script tries to execute (…/jre/bin/java), this will list the libraries it needs to execute and tell if it found them. lnx32 in the path of the complaining program is suggesting that it is a 32bit executable. Since you are on a 64bit host, you will most-probably need to install some 32bit libraries currently not present on your system.

2
  • If I run ldd ./xsetup I get not a dynamic executable. Any idea? Oct 13, 2015 at 13:24
  • Sorry, I wrote this ambiguous. See edit. Oct 14, 2015 at 8:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .