1

I am attempting to dual boot Linux Mint 17.2 (Cinnamon, 64 bit) and Windows 8.1 on my Acer E 15 (model # E5-573-55W1).

I have successfully installed Mint, but I can't get grub to start in a reasonable way. Here is what I have done:

  1. From Windows, create a new partition on my machine to install Mint onto
  2. Created a bootable USB drive
  3. Restarted my computer and pressed F2 to enter the bios settings:
    1. Bootmode: UEFI
    2. Secure Boot: Disabled
    3. Boot Order: USB HDD First
  4. Mint boots from the USB drive and I install:
    1. The installer didn't recognize that I had windows installed, so I selected the something else option (IE not the remove everything option).
    2. I created 3 new partition from the new partition that I made in windows, one for /, one for swap and one for /home.

enter image description here

Now I am confused, as to what my bios settings should be. I have the following set:

  • Bootmode: UEFI
  • Secure Boot: Disabled
  • Boot order: (see image)

enter image description here

When I boot, I don't get grub. I go directly to windows.


I know that my install worked because I was able to launch it through the grub on the USB. I can provide more detailed instructions on this if that would be helpful.


Full computer information:

enter image description here


The things that I am suspicious of right now are:

  • Bad bios settings
  • Wrong boot loader location

Edit

Reinstall with different boot loader location

I re-installed and set the Device for boot loader installation to sda2 but that didn't make any difference. Same behavior.


Edit

Steps to Boot into Linux Mint (in a unacceptably poor way):

  • In bios set the boot order to use the USB HDD

  • Grub will be launched. Press ESC:

enter image description here

  • Now you should be in Grub command mode. Exit it by typing exit:

enter image description here

  • Now you should be on the Boot Manager page. From here you can launch the right grub (IE the first option):

enter image description here

  • This is what the right grub looks like. The first option will launch the installed version of linux mint (complete with the username I created during install). The third option will start windows.

enter image description here

The only question remaining, is why can't I open this grub on startup? What bios settings do I need?

1 Answer 1

1

The answer was posted over at askUbuntu and it worked for me. Thanks @gio900. I have copy & pasted the answer below (to avoid broken links):

So I resolved in the simplest way:

  • let boot mode UEFI enable, secure boot enable
  • in bios added the USB boot file of the distribution I want to install as trusted for executing:
    • My bios is: Phoenix SecureCore Tiano Setup
    • under Boot I flag Boot Mode UEFI
    • Secure Boot ENABLE
    • under SECURITY i select: "Select an UEFI file as trusted for executing"
    • in "Available File System" i select fs0:$nameofmyusbkey
    • select [EFI]
    • select [BOOT]
    • select BOOTx64.EFI
    • give it the name "whateveryouwant" then, using tab, select YES.
    • so I go to the Boot option, then put "whateveryouwant" as first in the Boot priority order
    • then I was able to start Ubuntu installation in UEFI mode! :)

WARNIG!

before I did all them, I free the space for my partitions under win8, I read so many guide about UEFI and UEFI install (I give advice to do it!), and try in several way. That was the only way I was able to do what I want

Note: In order to add items to the boot priority order you must be have Secure Boot set to Enabled....

1
  • Your screen shots show you as having InsydeH20 firmware. It had exactly the same boot options?
    – fpmurphy
    Apr 21, 2016 at 7:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.