2

any ideas on this one? I'm trying to print to a CUPS printer running on Debian from a Mac running OSX 10.11 El Capitan. When I try to print, my /var/log/cups/error_log reads:

D [12/Oct/2015:00:59:04 +0100] [Client 3] Accepted from [v1.fe80::a65e:60ff:fec1:9b01+eth0]:55661 (IPv6)
D [12/Oct/2015:00:59:04 +0100] [Client 3] Waiting for request.
I [12/Oct/2015:00:59:04 +0100] [Client 3] Connection now encrypted.
D [12/Oct/2015:00:59:04 +0100] [Client 3] POST /printers/HomePrinter HTTP/1.1
D [12/Oct/2015:00:59:04 +0100] cupsdSetBusyState: newbusy="Active clients", busy="Not busy"
D [12/Oct/2015:00:59:04 +0100] [Client 3] Read: status=200
D [12/Oct/2015:00:59:04 +0100] [Client 3] No authentication data provided.
D [12/Oct/2015:00:59:04 +0100] [Client 3] cupsdSendHeader: code=403, type="text/html", auth_type=0
D [12/Oct/2015:00:59:04 +0100] [Client 3] Closing connection.
D [12/Oct/2015:00:59:04 +0100] cupsdSetBusyState: newbusy="Not busy", busy="Active clients"
D [12/Oct/2015:00:59:04 +0100] [Client 3] Waiting for socket close.
D [12/Oct/2015:00:59:04 +0100] [Client 3] Read: status=100
D [12/Oct/2015:00:59:04 +0100] [Client 3] Read: status=100
D [12/Oct/2015:00:59:04 +0100] [Client 3] Read: status=100
D [12/Oct/2015:00:59:04 +0100] [Client 3] Read: status=100
D [12/Oct/2015:00:59:04 +0100] [Client 3] Read: status=100

and then fills up the log file with millions (literally) of lines like this until the entire partition is full!

The Mac machine says: "Hold for authentication", but I'm not aware of having requested authentication in the CUPS configuration, so I'm really at a loss. I can post my cups configuration if that would be of help.

Any guidance would be gratefully appreciated!

Thanks, Julian

  • `code=403` that's HTTP 403 "Forbidden" – Jasen Dec 25 '16 at 6:38
  • Yes, indeed, Jasen. The answer below about IPv6 solved the issue, and the connections are no longer forbidden. – Julian Gilbey Dec 29 '16 at 19:06
1

I had this issue too. In my case, it turned out that a server-side configuration change was required, specifically, in "Admin" -> "Server", enable "Allow printing from the Internet".

Not quite certain why, but it seems that perhaps El Capitan is preferring IPv6 and CUPS on the server-side is interpreting this as an "Internet" access rather than local network.

HTH!

  • 1
    You're so right! Thank you. I'm using CUPS on a Linux machine, so I added this entry to my cupsd.conf file: Allow from [fe80::]/10 and now all works! – Julian Gilbey Dec 25 '15 at 10:49
  • @julian-gilbey Where should this directive be included in the cups.conf file? – Graham Jan 3 '16 at 15:20
  • @Graham I have it in my Location section, as follows (apologies about lack of newlines - I can't figure out how to put them in responses, so I've written \n instead): # Restrict access to the server...\n <Location />\n Order allow,deny\n Allow from localhost\n Allow from 192.168.0.*\n Allow from [fe80::]/10\n </Location> – Julian Gilbey Jan 19 '16 at 21:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.