I have several files with encoding issues in their file names (German umlauts, burned on CD with Windows, read by Windows and synced to Linux with Seafile. Something, somewhere went wrong...). Bash and zsh only show "?" instead of umlauts, stat shows something like

$ stat Erg�nzung.doc 
File: ‘Erg\344nzung.doc’
Size: 2609152         Blocks: 5096       IO Block: 4096   regular file
Device: 806h/2054d      Inode: 12321475    Links: 1

I can enter the filename only with autocompletion. How do I rename the file? The affected files seem to be unreadable by LibreOffice (or other programs for other file types), they complain about "No such file or device".

I was thinking about mv --by-inode 12321475 Ergänzung.doc, but there's no --by-inode switch for mv. What else can I do?


3 Answers 3


You could try:

find . -inum 12321475 -exec mv {} new-filename \;


find . -inum 12321475 -print0 | xargs -0 mv -t new-filename

Generally I prefer xargs over exec. Google for why. It's tricky though. See Find -exec + vs find | xargs. Which one to choose?

  • I tried, and it worked (with the -exec option, didn't try the xargs command)
    – Jasper
    Oct 11, 2015 at 13:59
  • 2
    With xargs -0, don’t you need find  … -print0? Oct 11, 2015 at 15:12
  • probably. like that ^ ? or please edit to correct syntax Oct 11, 2015 at 16:13

There is a utility convmv for this type of problem. It allows you to change the encoding of a filename from eg windows cp1256 to utf8, etc.


Just for the record, the correct xargs -0 usage is:

find . -inum 12321475 -print0 | xargs -0 -I '{}' mv '{}' new-filename

but as already pointed out it wasn't necessary anyway.

  • This one is the only solution on the page that worked Jan 25 at 20:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.