1

I upgraded from Squeeze to Wheezy without problems. But after upgrading to Jessie the system cannot boot anymore (using LILO).

LILO
ERROR: Duplicated Volume ID
O 24.1 Loading Linux ....(snip)
BIOS data check successful
Loading, please wait
[   14.948425] end_request: I/O error, dev fd0, sector 0
mdadm: /dev/md3 has been started with 1 drive (out of 2).
[   27.196906] end_request: I/O error, dev fd0, sector 0

...snip

modprobe: module unknown not found in modules.dep
fsck from util-linux 2.25.2
mount: mounting /dev/root on /root failed: No such file or directory

...etc.

And i get to the (initramfs) prompt

When I try to list partitions of one of the RAID disks they don't show up.

(initramfs) ls /dev/sda*
/dev/sda

Examining the disk says

(initramfs) mdadm --examine /dev/sda
/dev/sda:
          Magic : Intel Raid ISM Cfg Sig.

Although the onboard RAID controller is disabled in BIOS. When I access the disks with KNOPPIX (7.0.5) I can access and sync the partitions (sda1, sdc1) without problems. So I guess:

  • The RAID disks have been created some time in the past using the onboard RAID controller
  • Because debian didn't support ICH9 chipset the support for this was disabled in BIOS
  • Jessie seems to look not only at the superblocks of the partitions but also on the superblocks of disks and fails because they are identical?

How should I fix this problem?

  • Enable ICH9 raid in BIOS resync the disks there? Will the system boot?
  • Zero-out the superblocks using mdadm on the disks
  • 1
    Run mdadm --examine on /dev/sd* not just sda. Also show what /proc/mdstat looks in Knoppix where things work. If this is a pure Linux system and you're using FakeRAID it would probably be better to switch to mdadm's native format. – frostschutz Oct 10 '15 at 10:29
  • The same result as mdadm --examine /dev/sda comes for sdc (which is the duplicate. I'll try to switch back to the native format and provide the results here. – Gerd K Oct 11 '15 at 7:53
0

Finally I found a solution myself. So for anyone who runs into a similar problem:

First of all I made a full disk dump of the non-working raid disks using a live cd.

dd if=/dev/sda bs=10M | gzip -1 > /some/backup/drive/sda.img.gz
dd if=/dev/sdc bs=10M | gzip -1 > /some/backup/drive/sdc.img.gz

I rebooted and removed both disks from the array in the Intel Raid util (after BIOS). Then I booted again with the live cd.

dmraid automatically activated the disk raid. So I had to deactivate it

dmraid -an

Afterwards I checked the status of the partitions

mdadm --examine /dev/sda1
mdadm --examine /dev/sdc1

The sda disk had a wrong superblock. I fixed it and activated the raid.

mdadm --zero-superblock /dev/sda1
mdadm -A --run /dev/md0 /dev/sdc1
mdadm -add /dev/md0 /dev/sda1
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.