I am having difficulties installing Red Hat. Allow me to explain:

I have set up several systems now in a dual boot configuration with Windows and some distro of Linux. I thought I was pretty good at it.

But recently, I have not had such success. I built a PC with an SSD (Samsung EVO 500GB). I was able to put Windows 10 Education on it with relative ease. However, I need to have a Linux distro installed for work/school. I then began the steps I have taken many times to create a dual boot system.

  1. I downloaded the Red Hat Enterprise 7.0 iso and burned it to DVD. (I have also tried Linux Mint, Ubuntu, and Fedora all with the same similar problem.)

  2. I shrank the Windows Partition to only consume ~300GB of my SSD, leaving ~170GB of free, "unallocated" space.

  3. I then start my computer with the iso disk in my optical drive. I get the options to install Red Hat, scan Red Hat device and install, or Troubleshoot.

  4. 'Install Red Hat' and 'Scan Red Hat device and install' both have the same result, but when I scan and install it takes significantly longer as one would expect.

  5. After selecting one of the install methods, I am then warned that this hardware configuration hasn't been tested by RedHat. This was unsurprising to me since I have a skylake i7. After a while, the graphical installer begins.

  6. Now we get to the problem, regardless of which Linux distro I am attempting to install: When selecting the installation destination, I can see my SSD and the graphical interface correctly identifies that I have ~170GB of free space available. Yet upon selecting that drive and clicking 'done' I get the message popping up telling me that the drive(s) I have selected have 0 Bytes Free and 0 Bytes available for Reclamation. I also say "~170GB" because from attempt to attempt the installer reports different numbers in the range of 166GB-170GB of free space available. Perhaps this is a clue, but I don't know what it means. ALSO, if I select no drives at all after it tells me once about having 0 bytes free, then click done, then go back to the installation destination, it no longer reports ~170GB free, but some nonsensical amount: sometimes it's like 1MB and sometimes it says the whole dang thing is available (470GB). This sequence of steps also usually crashes the installer.

6.1. I would like to note that I also have a 3TB HDD. When I select that drive instead (with the free, "unallocated" block of 1.8TB (note that this block was freed in exactly the same way I freed space on my SSD, via Windows disk management)) it seems to be perfectly okay with that and allows me to automatically partition when I click 'done'. However, the entire reason I got an SSD was for my OS-es. Plus I don't even know if GRUB would be able to find my other OS (Windows 10) installed on the other drive. For these reasons, I have not continued with the installation when my HDD is selected as the install destination.

6.2 I talked with the IT support at my school once already about this problem and was given no answer whatsoever other than "never use automatic partitioning." "But why is it saying 0 Byt--"NEVER USE AUTOMATIC PARTITIONING." I explained I had done automatic partitioning several times in the past with no issues. No explanation was given to the problem I was having. I tried manual partitioning as instructed, following the recommended partition sizes and formats I found in the Red Hat installation guide. However upon setting up the partitions (all the while the installer correctly updated the shrinking amount of free space available on my SSD) and clicking 'done' I am told I don't have a bootable partition and some other error I don't recall. When I click 'done' again, it gives me a pop up of what it's going to do. Creating and formatting all the partitions I instructed it to is on the list, but it also sneakily wants to wipe out my Windows partition. Totally not okay.

Any idea what's going on or what to do?

Things I've tried:

  1. Numerous other Linux distros including: Linux Mint, Ubuntu, and Fedora. Same "0 bytes free" after showing me that it has lots of free space error.
  2. I verified that all drives/partitions are of type "Basic". I read that some people were having a similar error due to Windows doing its own, incompatible logical scheme for the type, but that if this is NOT the case, the drives will be listed as "Basic"-- as they are.
  3. I've also tried having the ~170GB partition given to Windows, then in the Red Hat installer I select that partition to be deleted and taken over by this installation. I still get the "0 bytes free" hogwash after I free it in the installer.

How is it that it recognizes that I have ~170GB free and then turns around to say I have 0 bytes free?

Thanks for any ideas,

Paul

Additional info:

Upon startup with the Red Hat Enterprise 7.0 iso DVD, I get the following on my screen:

[ 0.000000] Detected CPU family 6 model 94

[ 0.000000] Warning:Intel CPU model - this hardware has not undergone testing by Red Hat and might not be certified. Please consult https://hardware.redhat.com for certified hardware.

[ 0.001000] tsc: Fast TSC calibration failed

Error message after selecting my SSD as installation destination:

Your current "Fedora" software selection requires <11.63> GiB of available space, including <3.76> GiB for software and and 7.88 GiB for swap space. The disks you've selected have the following amounts of free space: 0 Free space available for use. 0 Free space unavailable but reclaimable for existing partitions.

You don't have enough space available to install "Fedora" shrink or remove existing partitions via our guided reclaim space tool, or you can adjust your partitions on your own in the custom partitioning interface.

"Fedora" can be replaced with the other Linux distros I've tried that have this installer (i.e. Red Hat) (and the GiB amounts vary as well).

I am aware I don't need a swap space that big, but that really isn't the issue here.

up vote 1 down vote accepted

Since the SSD is small enough for an MBR partition table as opposed to one of those modern ones, it is possible that your Windows installation is already using up the maximum of four primary partitions. If that is the case, it is technically impossible to add another partition, no matter how much space is available.

You can verify this is the cause by running fdisk -l on the SSD. If that lists four partitions numbered one through four, you're out of luck.

Alternatively, it may be the case that you do have an extended partition, but that the available space is not located at the end of that partition (and that you have no more primary partition which you could use). That, too, would make it impossible for a new partition to be created.

If neither of these solves your problem, please add the output of fdisk -l to your question.

  • Embarrassed that I missed this.. but in the properties of the SSD in the Windows disk manager it does list the SSD as MBR partitioning scheme (I had been lead astray by another post and thought I was in the clear since individual partitions were listed as "Basic"). So I followed Microsoft's instructions on changing from MBR to GPT. Apparently you can do this without data loss.. I didn't.. (thewindowsclub.com/convert-mbr-to-gpt-disk). No longer have the issue I made this post about, but am now plagued with many others.. very frustrating. – Paul Oct 16 '15 at 19:06

Something is definitely wrong with the partition table of your SSD. Most likely the only solution is to reinitialize the partition table using a LiveCD/LiveUSB and parted or similar... but rewriting the partition table will cause all partitions in the disk to be lost!

As your concern of GRUB not detecting Windows in other partition, so far I have tested and installed dual-boot in computers, GRUB never failed to locate Windows in any partition of any disk.

From your hint of Windows "doing its own, incompatible logical scheme with the [basic] format", although you say that is not the case (I don't know right know how to possitive/negative test it), it is something quite common of MS, to do their own thing.

That's why I never, ever design disk partitions using Windows to install other OS(s) afterwards, if I know that I am going to create a multiple-OS boot from the beginning. I do all of it with a LiveCD and parted or gparted, define all my partitions, and then letting Windows take only its partition, without changing anything using the management tools inside Windows.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.