1

I did an upgrade with yaourt -Syuu but when I rebooted, my Xfce didn't work. So I installed KDE and it worked perfectly.

When I tried to run firefox, this is the output:

process:5495): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' 
failed
firefox: symbol lookup error: /usr/lib/libpangoft2-1.0.so.0 If you want 
: undefined symbol: hb_buffer_set_cluster_level

with mousepad:

(mousepad:5517): GtkSourceView-CRITICAL **: gtk_source_style_scheme_get_id: assertion 'GTK_IS_SOURCE_STYLE_SCHEME (scheme)' failed

(mousepad:5517): GLib-CRITICAL **: g_variant_new_string: assertion 'string != NULL' failed

(mousepad:5517): GtkSourceView-CRITICAL **: gtk_source_style_scheme_get_id: assertion 'GTK_IS_SOURCE_STYLE_SCHEME (scheme)' failed

(mousepad:5517): GLib-CRITICAL **: g_variant_new_string: assertion 'string != NULL' failed

(mousepad:5517): GtkSourceView-CRITICAL **: gtk_source_style_scheme_get_id: assertion 'GTK_IS_SOURCE_STYLE_SCHEME (scheme)' failed
mousepad: symbol lookup error: /usr/lib/libpangoft2-1.0.so.0: undefined symbol: hb_buffer_set_cluster_level

and chromium:

/usr/lib/chromium/chromium --ppapi-flash-    path=/usr/lib/PepperFlash/libpepflashplayer.so --ppapi-flash-version=18.0.0.233: symbol lookup error: /usr/lib/libpangoft2-1.0.so.0: undefined symbol: hb_buffer_set_cluster_level

Searching a while I found libpangoft2-1.0.so is in lib32-pango or Pango.

sudo pacman -S lib32-pango
advertencia: lib32-pango-1.36.8-1 está actualizado -- reinstalando
resolviendo dependencias...
buscando conflictos entre paquetes....

Paquetes (1) lib32-pango-1.36.8-1

Tamaño total de la instalación:  0,50 MiB
Tamaño neto tras actualizar:    0,00 MiB

:: ¿Continuar con la instalación? [S/n] S
(1/1) comprobando las claves del depósito            [############################] 100%
(1/1) verificando la integridad de los paquetes      [############################] 100%
(1/1) cargando los archivos de los paquetes          [############################] 100%
(1/1) comprobando conflictos entre archivos          [############################] 100%
(1/1) comprobando el espacio disponible en disco     [############################] 100%
(1/1) reinstalando lib32-pango                       [############################] 100%
sbin/ldconfig: El fichero /usr/lib/libtracker-miner-1.0.so.0 está vacío, no se comprueba.
sbin/ldconfig: El fichero /usr/lib/libtracker-miner-1.0.so está vacío, no se comprueba.
sbin/ldconfig: El fichero /usr/lib/libtracker-control-1.0.so.0.600.0 está vacío, no se comprueba.
sbin/ldconfig: El fichero /usr/lib/libtracker-miner-1.0.so.0.600.0 está vacío, no se comprueba.
sbin/ldconfig: El fichero /usr/lib/libtracker-control-1.0.so.0 está vacío, no se comprueba.

Also, I tried reinstalling glib2, glib gtk and gtk2 but none of it worked.

  • 1
    Don't upgrade your system with yaourt. That way of upgrading is completely unsupported and unofficial. No wonder Xfce4 broke. – Alexander Feb 28 '17 at 18:06
0

I had the same failure message from several Applications (!) when I upgraded pango these days (on OpenSuSE_Tumbleweed).

In the OpenSuSE mailing list is a thread about the same problem with the AcrobatReader. There I figured out, that it has to do with dependencies from Pango to Harfbuzz ("hb_buffer . . ."). So I upgraded libharfbuzz from 0.9.9 to 1.0.3. and everything worked fine again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.