0

I am using Linux Mint on my laptop with a standard Qwerty keyboard. Is there any way of me using the same United States International keyboard layout like on Windows? So ") immediately works and shift ' twice won't end up with 2 dots in the air.

I just want my keyboard layout to act 100% like Windows' United States International keyboard.

1
  • Please edit your question and describe how the Windows keyboard works. Most of us have no idea how Windows does things since we don't use it. Also, please tell us precisely which keyboard layout you are using (edit your question and add the output of this command: setxkbmap -print | grep xkb_symbols). – terdon Oct 22 '15 at 12:52
1

Not being in the US I don't know the specifics of a standard United States International keyboard. However, if by a standard keyboard you mean one that doesn't use dead keys (so quotes appear immediately rather than accenting characters) this should be set up almost as part of the standard installation. If this isn't what you need then it would help in the international community to explain what it is that you want.

If you need to access accented characters then consider enabling the Compose Key. The Compose Key is a prefix key that tells the system to take the next two characters and combine them "visually" to create a single character. For example, Composeo" will result in the single character ö. And so on.

4
  • The problem is, if I want a ) after a " I can't do press " and then ), but I have to press ", then space, then ) which is more work. That character work, but when I press shift and " two times, there should be "", but I get this weird char: ¨. In windows, shift + " two times result in "", and " followed by ) will result in "). In Linux, it won't display anything. Same with ' and t, it won't display the 't I want. Hopefully I explained it a little bit better. – Joshua Bakker Oct 7 '15 at 19:04
  • @JoshuaBakker: ah. Use the standard US keyboard. Don't take the one with "international" in the name as that's the one that provides "dead keys". – roaima Oct 7 '15 at 20:00
  • It works, but then things like ö won't work. I don't have a compose key or something. Also this still doesn't really act like Windows. – Joshua Bakker Oct 7 '15 at 20:42
  • @JoshuaBakker you need to enable the Compose Key for whatever GUI it is that you're using. I have mine bound to Right Alt, for example. Like I said though initially, without knowing what your Windows baseline is, I can't give any more of a specific answer. – roaima Oct 7 '15 at 20:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.