1

I would like to be able to use Docky or Plank in Manjaro Fluxbox, but they do not work well.

A large band of shadow appears close to the dock. This shadow is there even when the dock is hidden.

This area cannot be clicked through and any window under it, just like a whole part of the desktop, is thus unaccessible.

enter image description here

I have tested mostly Plank but similar problems albeit some different are present with the others.

(Wbar works fine, but it has a different logic I suppose.)

0
+50

The phenomenon, which you described as "a large band of shadow", is likely because the window manager Fluxbox is not using any compositing manager.

Modern docks such as docky and plank relies on a compositing manager for its appearance rendering and animation effects. This is a default, therefore compositing is required for these docks and there is no way to skip this requirement (when using earlier releases of plank).

Latest solution: Update plank

As release 0.10.1, the dock seems to support both compositing and non-compositing environments properly. I have tested this release on Xfce 4.10 with Xfwm.

Solution 1: Compositing

You will need a compositing manager that works with Fluxbox. According to this Wiki, the only option with Fluxbox is compton. Not much details, but someone had managed.

Solution 2: Non-compositing

Use other dock that works even without compositing, such as avant-window-navigator and cairo-dock. The latter seems to work better with compositing. These docks will have solid background when used in non-compositing mode. No compositing means no transparency.

Related experience

I have experienced this phenomenon when I had tested docky and plank during its early development in GNOME 2 and Xfce environments. These X environments had their built-in compositing managers, Metacity and Xfwm, which can be turned on and off easily.

This area cannot be clicked through and any window under it, just like a whole part of the desktop, is thus unaccessible.

However, I didn't remember the shadow had prevented me from clicking the launchers on the dock (it was some time ago, so I can't recollect my testing experience entirely).

Additional notes

Fluxbox Wiki had this howto that explains how to use compositing with Fluxbox using xcompmgr, which was said to be "nothing but eyecandy". Since its development had discontinued, its fork compton took over the role, which notably known for its solution to "tear-free experience" in Xfce.

Dock with compositing and non-compositing

To describe the difference between two solutions above, I have used avant-window-navigator in Xfce environment to demonstrate the effect.

AWN on Xfce with compositing enabled

In the first screenshot, the information dialog is partially visible under semi-transparent dock background and has drop down shadows around the information dialog itself.

AWN on Xfce with compositing disabled

In the second screenshot, the information dialog is no longer visible and hidden under the light grey solid background and no more shadows.

  • Cairo has the same problem, somewhat different in that the clicking-through worked. - Compton was installed and running. - I will try avant-window-navigator. – user32012 Oct 10 '15 at 22:59
  • AWN has exactly the same problem as the rest. I have one kind of a dock that does not need compositing, Wbar, which is present by default in Manjaro Fluxbox. – user32012 Oct 10 '15 at 23:13
  • In fact, after installing Fluxbox from scratch, that is on top on Lubuntu, the dock Plank works without compton. – user32012 Oct 14 '15 at 9:47
  • 1
    Updated with latest solution. Latest releases of plank seems to handle non-compositing properly. The issue is not in Fluxbox, but the dock. – clearkimura Oct 15 '15 at 13:05
0

In Manjaro Fluxbox 15.10 Plank not only works, but is installed and running by default.


In fact, after installing Fluxbox from scratch, that is on top of Lubuntu, the dock Plank works without compton. On the contrary, compton was installed and running in Fluxbox Manjaro 15.09.

The shadow appeared because the program was started with the command compton -c, which stays for "Enabled client-side shadows on windows". Running it without any argument avoids the shadow, but a part of the screen near to the dock is still reserved and not accessible. This is solved by disabling compton completely in Fluxbox. Plank will work, but without certain features like zoom. Removing compton also solves other problems like losing window frame of terminals.


There must be another solution of running Plank with full features along compton, as it happens in Manjaro Fluxbox 15.10. I have to investigate and see what compton arguments make it possible.

  • The OP is asking why it doesn't work in 15.09 - this doesn't really answer his question, it's more a "It works for me, I'm on 15.10", is it broken in 15.09? Are you suggesting they upgrade to 15.10 ? – X Tian Oct 12 '15 at 12:25
  • @XTian :) I am the OP. I should have posted this inside the question maybe. But yes, going up to 15.10 solves it. – user32012 Oct 12 '15 at 12:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy